Search found 2669 matches

by sirmorris
Fri Nov 24, 2017 3:42 pm
Forum: Emulators
Topic: Which emulator and assembler for the Mac?
Replies: 16
Views: 562

Re: Which emulator and assembler for the Mac?

Here. It's a bit cheap. And because of mirroring excuses it reports RAM above 48k. So don't trust it.
by sirmorris
Fri Nov 24, 2017 3:27 pm
Forum: Hardware
Topic: Help with Homemade ZX80-81- HIRES problem
Replies: 37
Views: 479

Re: Help with Homemade ZX80-81- HIRES problem

Great news! Congratulations :D
by sirmorris
Fri Nov 24, 2017 8:08 am
Forum: Emulators
Topic: Which emulator and assembler for the Mac?
Replies: 16
Views: 562

Re: Which emulator and assembler for the Mac?

Thanks! I appreciate this very much. It's made development of ... the thing I'm doing ... a little easier!
by sirmorris
Thu Nov 23, 2017 6:38 pm
Forum: Welcome Area
Topic: Happy Thanksgiving
Replies: 5
Views: 59

Re: Happy Thanksgiving

Happy Thanksgiving!
by sirmorris
Tue Nov 21, 2017 10:23 pm
Forum: Hardware
Topic: TS1500 and ZXPand
Replies: 6
Views: 80

Re: TS1500 and ZXPand

They are a very worthwhile upgrade. It has to be said.
by sirmorris
Tue Nov 21, 2017 2:26 pm
Forum: Hardware
Topic: TS1500 and ZXPand
Replies: 6
Views: 80

Re: TS1500 and ZXPand

Nice job! However I feel I should warn about the fact that both the ZXpand and the TS1500 can simultaneously try to drive the bus when accessing RAM above 32k. When the '1500 has external memory pulling on its RAMCS line on the edge connector it remaps the internal 16k to sit at 32k. If you start PO...
by sirmorris
Tue Nov 21, 2017 8:45 am
Forum: Hardware
Topic: zx spectrum in zx81 case
Replies: 13
Views: 242

Re: zx spectrum in zx81 case

:ugeek: Superb.
by sirmorris
Mon Nov 20, 2017 7:22 pm
Forum: Hardware
Topic: Help with Homemade ZX80-81- HIRES problem
Replies: 37
Views: 479

Re: Help with Homemade ZX80-81- HIRES problem

Using a pencil and a piece of paper try to work out what address range the correct portion of the image occupies. This will give some clues I think.
by sirmorris
Mon Nov 20, 2017 6:36 pm
Forum: Hardware
Topic: Help with Homemade ZX80-81- HIRES problem
Replies: 37
Views: 479

Re: Help with Homemade ZX80-81- HIRES problem

Yes but do you see that the image is correct in that stripe? It looks to me like there is a problem with memory decoding. It seems that for a small region of the display it is correct, for the rest there is something happening. It would be interesting to see what address is correctly displayed.
by sirmorris
Mon Nov 20, 2017 5:31 pm
Forum: Hardware
Topic: Help with Homemade ZX80-81- HIRES problem
Replies: 37
Views: 479

Re: Help with Homemade ZX80-81- HIRES problem

I've only just noticed the band where the image looks correct, you have highlighted it in your original images. Is this static on screen or does it sweep from top to bottom?