Lambda 8300 ULA

gozzo
Posts: 444
Joined: Fri Jul 08, 2011 7:52 pm

Re: Lambda 8300 ULA

Post by gozzo » Thu Mar 03, 2016 7:29 pm

No, a ZX81 ULA wont work in a Lambda, or the other way round, there appears to be no area of the Lambda ROM that has the character bit patterns(well, i cant find them!)unlike the ZX81 ROM, which has them at the top 512 bytes..only possible conclusion is that they are stored elsewhere and as no other ROM, the Lambda ULA must also have a ROM section in it somewhere!!!

gozzo
Posts: 444
Joined: Fri Jul 08, 2011 7:52 pm

Re: Lambda 8300 ULA

Post by gozzo » Thu Mar 03, 2016 7:31 pm

May be possible to make an adaptor board to take a ZX81 ULA plus extra EPROM for the character patternss, plus its decoding circuit, also the Lambda has crude sound capabilities, not sure how this is achieved!

User avatar
1024MAK
Posts: 1768
Joined: Mon Sep 26, 2011 9:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Lambda 8300 ULA

Post by 1024MAK » Fri Mar 04, 2016 1:46 am

Pictures from mine:-
image.jpg
"ULA" C4005
image.jpg (246.84 KiB) Viewed 1034 times
image.jpg
Z80 CPU
image.jpg (347.67 KiB) Viewed 1034 times
image.jpg
ROM AMI 8444FC
10830-21103-01
image.jpg (188.69 KiB) Viewed 1034 times
image.jpg
SRAM TMM2016P-1
image.jpg (425.92 KiB) Viewed 1034 times
image.jpg
Board
image.jpg (467.3 KiB) Viewed 1034 times
Mark

nollkolltroll
Posts: 188
Joined: Sat Sep 27, 2014 7:02 pm
Location: Stockholm, Sweden

Re: Lambda 8300 ULA

Post by nollkolltroll » Fri Mar 04, 2016 7:07 am

There is great documentation on the Lambda in a section at http://problemkaputt.de/zxdocs.htm, including where font is stored and sound capabilities.
/Adam

User avatar
mrtinb
Posts: 504
Joined: Fri Nov 06, 2015 4:44 pm
Location: Denmark
Contact:

Re: Lambda 8300 ULA

Post by mrtinb » Fri Mar 04, 2016 3:41 pm

RWAP wrote:Are you sure it's the ULA at fault?
I havn't measured the Lambda 8300 yet. 1st project is to get the ZX81 running again.
gozzo wrote:May be possible to make an adaptor board to take a ZX81 ULA plus extra EPROM for the character patternss, plus its decoding circuit, also the Lambda has crude sound capabilities, not sure how this is achieved!
What I've read, the Lambda will work with a ZX81 ROM, but not with graphics or pseudo graphics. Somehow they must be quite similar.

Martin
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
mrtinb
Posts: 504
Joined: Fri Nov 06, 2015 4:44 pm
Location: Denmark
Contact:

Re: Lambda 8300 ULA

Post by mrtinb » Sun Oct 16, 2016 5:19 pm

Maybe some of the creators of the emulators know how the ULA in Lambda 8300 is different from the ULA. How the char ROM is connected to the rest of the ULA, or even how similar the ULAs are.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

olofsen
Posts: 123
Joined: Wed Jan 08, 2014 11:29 am

Re: Lambda 8300 ULA

Post by olofsen » Tue Oct 18, 2016 5:14 pm

Emulator code for the ZX81 also runs the Lambda, with the exceptions mentioned by gozzo: sound and the character bit patterns. The ZXmore runs the Lambda, if the I register is set to for example $3e (normally 0) to point at character bit patterns loaded in RAM at address $3e00. This suggests that a ULA replacement board could indeed work, with logic added to get the bit patterns from another ROM instead of the first pages of the Lambda ROM.

User avatar
PokeMon
Posts: 2129
Joined: Sat Sep 17, 2011 5:48 pm

Re: Lambda 8300 ULA

Post by PokeMon » Tue Oct 18, 2016 7:02 pm

I didn't try out that.
Did you try flash rom as well or has to be RAM ?

olofsen
Posts: 123
Joined: Wed Jan 08, 2014 11:29 am

Re: Lambda 8300 ULA

Post by olofsen » Wed Oct 19, 2016 6:50 am

The flash ROM should also work, but I haven't tried it; the area $2000 - $3000 is also used to store colour information (http://problemkaputt.de/zxdocs.txt). By the way, ports $f5 and $f6 seem to be used by the printer (http://sinclairzxworld.com/viewtopic.php?f=18&t=1681) so printing could have spectacular effects ;)

User avatar
PokeMon
Posts: 2129
Joined: Sat Sep 17, 2011 5:48 pm

Re: Lambda 8300 ULA

Post by PokeMon » Wed Oct 19, 2016 10:24 am

olofsen wrote:The flash ROM should also work, but I haven't tried it; the area $2000 - $3000 is also used to store colour information (http://problemkaputt.de/zxdocs.txt). By the way, ports $f5 and $f6 seem to be used by the printer (http://sinclairzxworld.com/viewtopic.php?f=18&t=1681) so printing could have spectacular effects ;)
Okay - it shouldn't be a problem to change the i/o address with the install program (ZXmorexx.p) to a different address line than A3.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest