LAMBDA PC 8300 BLACK DISPLAY

Post Reply
crowded
Posts: 2
Joined: Thu Jan 12, 2017 11:57 am

LAMBDA PC 8300 BLACK DISPLAY

Post by crowded » Thu Jan 12, 2017 7:39 pm

Hi members,
i have newly bought a lambda pc 8300 computer but unfortunately when i put the power jack of 12 V to the computer socket the red light turns on and a beep sound heard but only black display there is no cursor. i compared the motherboard i have with some pc 8300 motherboards on the net and realised that there are four 2114 ram chip slots on the board but there is none of them. i want to know if there should be those chips on the board to have it work properly.

Image

User avatar
mrtinb
Posts: 524
Joined: Fri Nov 06, 2015 4:44 pm
Location: Denmark
Contact:

Re: LAMBDA PC 8300 BLACK DISPLAY

Post by mrtinb » Sun Feb 19, 2017 7:30 pm

Not many people have these machines, so not many answers. (Mine is non-working stowed away, gives only black screen.)

Looking at this http://www.museo8bits.com/lambda.htm it looks like either there is 4 small chip OR 1 big.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
mrtinb
Posts: 524
Joined: Fri Nov 06, 2015 4:44 pm
Location: Denmark
Contact:

Re: LAMBDA PC 8300 BLACK DISPLAY

Post by mrtinb » Sun Feb 19, 2017 7:45 pm

I found mine in the bottom of my closet.

Image

The boards look different. I have 4 small chips as well, but not the vertical one.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

gozzo
Posts: 444
Joined: Fri Jul 08, 2011 7:52 pm

Re: LAMBDA PC 8300 BLACK DISPLAY

Post by gozzo » Sun Feb 19, 2017 7:52 pm

those are ram 'options' either one big 2k 8bit (6116 or similar) or 4 1k 4bit (2114 or similar) , to make 2k ram...depends on what they could get at the time i suppose!

User avatar
mrtinb
Posts: 524
Joined: Fri Nov 06, 2015 4:44 pm
Location: Denmark
Contact:

Re: LAMBDA PC 8300 BLACK DISPLAY

Post by mrtinb » Sun Feb 19, 2017 7:56 pm

Usually the chip that stops working is the ULA (here C4005).

Unfortunately these are custom made chips. And this version is custom made for the Lambda 8300.

I was hoping in the future to create a ULA clone for the ZX81 in a CPLD, and when that is working, maybe modify it to work on the Lambda 8300. The custom ULA in the Lambda 8300 includes a ROM with the characters as well (and not like the ZX81, where the characters are stored in the BASIC ROM).
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
TMAOne
Posts: 120
Joined: Thu Aug 16, 2012 5:56 pm
Location: Waterloo, Ontario, Canada

Re: LAMBDA PC 8300 BLACK DISPLAY

Post by TMAOne » Mon Feb 20, 2017 4:23 am

I have a working one, but I do have to fiddle with the brightness and contrast controls on my period black & white TV to see the READY prompt and the cursor. The beep sounds right, like the machine is booting. Maybe just a video problem? Have you tried the monitor output?
HPIM1402.JPG
HPIM1402.JPG (2.26 MiB) Viewed 640 times

crowded
Posts: 2
Joined: Thu Jan 12, 2017 11:57 am

Re: LAMBDA PC 8300 BLACK DISPLAY

Post by crowded » Thu Jul 06, 2017 9:44 am

i have not checked from monitor output yet. i will try as soon as possible. Thanks ;)

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest