ZX Spectrum Issue 3 repair

Tezz
Posts: 161
Joined: Thu Mar 09, 2017 7:28 pm

Re: ZX Spectrum Issue 3 repair

Post by Tezz » Sat Jun 03, 2017 1:59 pm

I checked the pins and tracks for IC3 and they looked ok so I tried 74HCT157N but no change. I went to take it out of the socket and it was totally wedged in, I couldn't use a puller or lever it out, I've never seen that occur before. Eventually forced it out of the socket with leverage which lifted the contacts out of the socket too. Perhaps there was a problem with the socket after all. I've now removed the broken socket and after some effort I've also removed IC4. Tracks and pads look fine fortunately so I'll install sockets and try the two HCT157Ns next.
Last edited by Tezz on Sat Jun 03, 2017 4:43 pm, edited 1 time in total.

Tezz
Posts: 161
Joined: Thu Mar 09, 2017 7:28 pm

Re: ZX Spectrum Issue 3 repair

Post by Tezz » Sat Jun 03, 2017 4:11 pm

Success! I installed the two sockets for IC3 / IC4 and used one of the new 74HCT157N chips along with the SN74LS157N that was originally socketed, I then installed a lower RAM module and the board is finally working :) So.. it looks like either that socket or the soldered SN74LS157N was the problem. I will need to buy a new 74HCT157N for the upper RAM upgrade as the one I had to force out of the old socket was too bad to reuse. One of the EAR or MIC sockets has a broken clip so I'll need to replace that as well as the capacitors to make sure that I've not just done half a job.

User avatar
1024MAK
Posts: 1768
Joined: Mon Sep 26, 2011 9:56 am
Location: Looking forward to summer in Somerset, UK...

Re: ZX Spectrum Issue 3 repair

Post by 1024MAK » Sat Jun 03, 2017 4:20 pm

Well done 8-) :D

Another Speccy brought back to life :D

Mark

Tezz
Posts: 161
Joined: Thu Mar 09, 2017 7:28 pm

Re: ZX Spectrum Issue 3 repair

Post by Tezz » Sun Jun 04, 2017 9:47 am

Thanks for your advice again Mark.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest