DivMMCx2 and Spectrum 128k +2 Grey case

repetto74
Posts: 43
Joined: Tue Dec 20, 2016 7:46 pm

DivMMCx2 and Spectrum 128k +2 Grey case

Post by repetto74 » Thu May 04, 2017 5:28 pm

Hi Guys,

I am using a DIVmmcx2 (from 8bit4ever) with a ZX spectrum and all working good. I would like to use it with a 128K +2 Grey case Spectrum. The manual is stating that jumper settings are the same for both ZX Spectrum and the 128k +2 but I just cannot get it to work. I am using the same SD card as the one for the ZX Spectrum (the card is filled with a full Spectrum game catalogue for both 48k and 128k machines). Sometimes I can get to the SD root folder but then it will freeze when selecting a folder and sometimes it will not boot at all into the root folder.
Is the ESXDOS to be copied into the card the same for both machines ? I am stuck :|

User avatar
1024MAK
Posts: 1768
Joined: Mon Sep 26, 2011 9:56 am
Location: Looking forward to summer in Somerset, UK...

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by 1024MAK » Thu May 04, 2017 8:22 pm

First, have you cleaned and checked the edge connector?

Mark

repetto74
Posts: 43
Joined: Tue Dec 20, 2016 7:46 pm

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by repetto74 » Thu May 04, 2017 9:59 pm

Hi 1024mak,

Thanks for the advice I will give the connector a good cleaning ;) and see the result.

User avatar
sirmorris
Posts: 2664
Joined: Thu May 08, 2008 4:45 pm
Location: oxon, uk

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by sirmorris » Thu May 04, 2017 10:02 pm

Z80 with weak M1?
--=== ZXpand+ ... A more moderner all-in-one upgrade solution for ZX81 ===--
* SD/MMC storage * 32K Hires-capable RAM * AY sound chip * Joystick port * Serial *
* BASIC enhancements - plug & play * Reset button * Auto-boot facility *

User avatar
1024MAK
Posts: 1768
Joined: Mon Sep 26, 2011 9:56 am
Location: Looking forward to summer in Somerset, UK...

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by 1024MAK » Thu May 04, 2017 11:33 pm

sirmorris wrote:
Thu May 04, 2017 10:02 pm
Z80 with weak M1?
Maybe, but only the models originally sold by Sinclair before the Amstrad takeovers were (allegedly) supposed to be affected. It is however possible that the Z80 CPU has suffered damage and the /M1 pin no longer functions correctly.

Mark

repetto74
Posts: 43
Joined: Tue Dec 20, 2016 7:46 pm

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by repetto74 » Fri May 05, 2017 5:17 pm

So I have opened the case and had a look inside (pictures) 8-)

First I do think this MB has been already repaired as the OS chip looks quite new, it is an EPROM and not sure this was fitted originaly. There is also a big heatsink on a chip.
Now I have noticed that the Z80 was not correctly seating on its socket and had to push it a little bit to fully secure it. Having said that I have noticed that video quality has now improved a lot (I have opened a thread for this video issue) but still some rumors on screen.
I have cleaned the port connector with alcohol and tested again the DivMMCx2. I could finally load the root folder of the SD card and access a game folder. I loaded a game successfully (Robocop) but noticed that sound volume is weak by default and I have to adjust a lot the TV volume with quiet a lot of background noise.
Problem is that the SD card loading then will always fail again as before one the DIVmmc is reset. Tried to power off and up but I cannot have the SD card read by the DIVMMC.
I may have too many files on it (tested working anyway on the ZX Spectrum 48k) or another ESXdos version is needed.
Very strange behaviour. :roll:


EDIT : Ok I may have fixed the DIVMMC issue. I was not aware but the Spectrum 128k needs the DIVMMC module to be initialized with the reset switch+Space combo :lol: I have tested and looks ok now 8-) even if initializing is a little bit tricky as you need the correct timing when hitting the space bar. Sorry for that unfortunately there is really poor documentation on how to operate the DivMMC reader :geek:
Attachments
IMG_5984.JPG
IMG_5984.JPG (1.66 MiB) Viewed 516 times
IMG_5983.JPG
IMG_5983.JPG (2.36 MiB) Viewed 516 times

repetto74
Posts: 43
Joined: Tue Dec 20, 2016 7:46 pm

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by repetto74 » Sat May 06, 2017 1:30 pm

Sorry guys I spoke to soon :oops:
Nope there is definitely no way to have the DIVMMc to boot the SD card. I managed once to get it running and load a game. I tried again to clean the connector and also pins of socketed IC's. The machine is running ok, I can use the cassette loader and tried to load successfully a game from an old tape compilation I had here but the DIVMMC refuses to work. I can basically see that the EXSDOS loading failed each time. :?

repetto74
Posts: 43
Joined: Tue Dec 20, 2016 7:46 pm

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by repetto74 » Sun Jul 02, 2017 5:35 pm

Hi guys,

I am still having troubles to get a 128k Grey Spectrum to work with the Divmmcx2 reader. I am using this reader succesfully with a ZX Spectrum and EXDOS 0.86 beta 4 loaded.
Actually I can get into the NMI Menu and browse for games on a first try but then after a reset there is no way to have EXDOS loaded again. Pissing me off :evil:
If someone with the same config can let me know if he had this problem and how to fix it? :?:

repetto74
Posts: 43
Joined: Tue Dec 20, 2016 7:46 pm

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by repetto74 » Thu Aug 24, 2017 11:29 am

Hi Guys,

I am moving this thread up back to life again and try to explain better what the issue is. Looking especially for some guidance on which part to test on the board. 8-)

*******************************************************************
I am trying to figure out why the DivMMC reader do not work on a Spectrum 128k +2 grey I grabbed recently over the net.
What is for sure is that :
- the DIVMMC reader is not faulty and works perfectly with a ZX Spectrum 48k
- the Spectrum 128k +2 is working apparently normally. It will power up and I do have the starting menu. The prompt is normal and writing basic instructions is ok.
- the Spectrum 128k +2 will also load a program/game directly from cassette tape and they do work normally.

So the machine behaviour seems to be fairly right but when using the DivMMC into the I/O expansion port I cannot load the content of the SD card or I do have an access to the card menu on firs boot but then everything will crash after a short period of time without any possibility to boot the DivMMC again.
After a certain cool down period the Divmmc will boot on first power up and then crash again.(garbled menu or menu freeze).

I do suspect a component regulating the I/O expansion data com which may be stop working normally when heating.
Does anyone knows some technicals for this machine and try to guide me through any component which could be the culprit?? :?:

Many thanks
Rick

User avatar
1024MAK
Posts: 1768
Joined: Mon Sep 26, 2011 9:56 am
Location: Looking forward to summer in Somerset, UK...

Re: DivMMCx2 and Spectrum 128k +2 Grey case

Post by 1024MAK » Thu Aug 24, 2017 12:35 pm

Can you post a close up photo of the top of the PCB for the DivMMC please.

Mark

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest