ANN: Spud81

Emulator and emulator development specific topics
karingal
Posts: 26
Joined: Mon Feb 04, 2013 1:30 pm

ANN: Spud81

Post by karingal » Wed Feb 06, 2013 11:55 am

I don't think this was ever announced this on here so may I proudly present...

Spud81

I don't intend adding any more features to it but if you do think of something then let me know and I'll consider it or if you find a bug then I'll definitely fix it.

User avatar
sirmorris
Posts: 2667
Joined: Thu May 08, 2008 4:45 pm
Location: oxon, uk

Re: ANN: Spud81

Post by sirmorris » Thu Feb 07, 2013 12:31 pm

A new emulator on the block? Cool! I'll give it a whizz!

C
--=== ZXpand+ ... A more moderner all-in-one upgrade solution for ZX81 ===--
* SD/MMC storage * 32K Hires-capable RAM * AY sound chip * Joystick port * Serial *
* BASIC enhancements - plug & play * Reset button * Auto-boot facility *

dr beep
Posts: 1045
Joined: Thu Jun 16, 2011 7:35 am
Location: Boxmeer

Re: ANN: Spud81

Post by dr beep » Thu Feb 07, 2013 1:58 pm

karingal wrote:I don't think this was ever announced this on here so may I proudly present...

Spud81

I don't intend adding any more features to it but if you do think of something then let me know and I'll consider it or if you find a bug then I'll definitely fix it.

Can't get ANY .P to load
Last edited by dr beep on Thu Feb 07, 2013 9:05 pm, edited 1 time in total.

User avatar
Andy Rea
Posts: 1267
Joined: Fri May 09, 2008 1:48 pm
Location: notts UK

Re: ANN: Spud81

Post by Andy Rea » Thu Feb 07, 2013 6:28 pm

Cool, i'll give it a go later, i'll give it something difficult to work with :D


Andy
6 x ZX81, 1 x TS1500 , 1 x +3e, 1 x timex 2040 printer, 1 x timex 2020 cassette deck, siclair printer and some spectrum

karingal
Posts: 26
Joined: Mon Feb 04, 2013 1:30 pm

Re: ANN: Spud81

Post by karingal » Fri Feb 08, 2013 12:15 am

dr beep wrote:
karingal wrote:I don't think this was ever announced this on here so may I proudly present...

Spud81

I don't intend adding any more features to it but if you do think of something then let me know and I'll consider it or if you find a bug then I'll definitely fix it.

Can't get ANY .P to load
Load File then LOAD "" <ENTER>

Sorry it's a bit complicated...

dr beep
Posts: 1045
Joined: Thu Jun 16, 2011 7:35 am
Location: Boxmeer

Re: ANN: Spud81

Post by dr beep » Fri Feb 08, 2013 8:34 am

I tested some 1K hires games since these don't use any standard screenroutine with a buffer of 6k or so.

SPUD passed the tests!

karingal
Posts: 26
Joined: Mon Feb 04, 2013 1:30 pm

Re: ANN: Spud81

Post by karingal » Fri Feb 08, 2013 11:47 am

dr beep wrote:I tested some 1K hires games since these don't use any standard screenroutine with a buffer of 6k or so.

SPUD passed the tests!
Hoorah!!!!!

(and a little bit relieved...)

User avatar
Andy Rea
Posts: 1267
Joined: Fri May 09, 2008 1:48 pm
Location: notts UK

Re: ANN: Spud81

Post by Andy Rea » Fri Feb 08, 2013 4:36 pm

here we go, i've thrown my stuff at it and here are the results....

If no sound device is avai;able Spud81 fails to launch after message box telling you that direct-sound failed to create an object.

The debugger causes a crash when single stepping the JP (HL) instruction

Zon-x ports... there is some confusion surrounding the correct ports, however by working from a real ZON-X it has been noted that A4 is not took into consideration when decoding the port addresses, the up-shot is that ports $CF and $DF are one and the same, as are ports $0F and $1F... so when driving the ay emulation for ZON-X you need to allow for this dual port business.

download CLCKFREQ.P and ZXTEST2.P available here viewtopic.php?t=685&p=6120#p6120

CLCKFREQ reports an overly optimistic speed when compared to a real ZX81.

ZXTEST2.P what should happen is the whole screen bobs up and down by 1 pixel line, Spud81 and Eightyone (along with some chardware clone machines ) fail this one :D

some other thoughts, definitely work on a better tape gui, add more border sizes, personally i like the small ( only a few pixels wide )

anyway it's really great work, much better than the hacky thing i did some time back, since lost into the either

Regards Andy
6 x ZX81, 1 x TS1500 , 1 x +3e, 1 x timex 2040 printer, 1 x timex 2020 cassette deck, siclair printer and some spectrum

karingal
Posts: 26
Joined: Mon Feb 04, 2013 1:30 pm

Re: ANN: Spud81

Post by karingal » Sat Feb 09, 2013 12:18 am

Andy Rea wrote:here we go, i've thrown my stuff at it and here are the results....

If no sound device is avai;able Spud81 fails to launch after message box telling you that direct-sound failed to create an object.
Thank for that one, as I've always had a sound device I never tested that!!
The debugger causes a crash when single stepping the JP (HL) instruction
I've used this debugger in 3 emulators now and you're the 1st person to report that bug, I'll fix that (in all 3 emulators!!!).
Zon-x ports... there is some confusion surrounding the correct ports, however by working from a real ZON-X it has been noted that A4 is not took into consideration when decoding the port addresses, the up-shot is that ports $CF and $DF are one and the same, as are ports $0F and $1F... so when driving the ay emulation for ZON-X you need to allow for this dual port business.
Easy fix, done.
download CLCKFREQ.P and ZXTEST2.P available here viewtopic.php?t=685&p=6120#p6120

CLCKFREQ reports an overly optimistic speed when compared to a real ZX81.

ZXTEST2.P what should happen is the whole screen bobs up and down by 1 pixel line, Spud81 and Eightyone (along with some chardware clone machines ) fail this one :D
Dunno why it's shown to be running a tad fast, not going to worry though, no-one will notice!!

Hmm, I'll look at the display routines, dunno if I can fix though.
some other thoughts, definitely work on a better tape gui, add more border sizes, personally i like the small ( only a few pixels wide )
There is no tape GUI!!, currently Spud81 only loads the .p format. Is there any other format I should consider?
anyway it's really great work, much better than the hacky thing i did some time back, since lost into the either

Regards Andy
Ta!!

User avatar
Andy Rea
Posts: 1267
Joined: Fri May 09, 2008 1:48 pm
Location: notts UK

Re: ANN: Spud81

Post by Andy Rea » Sat Feb 09, 2013 9:56 am

Hi Karingal,

With regards to the display failing to bob up and down by 1 scanline, but instead disrupting the characters i believe is to do with your simulation of the hardware specifically the hsync generator...

the counter for which can ONLY be reset by an INTACK which normally happens at the end of each scan-line after the CPU is halted and then bit 6 of the R register goes low. the Hsync ( and the increment of the internal character line counter) occurs 16 cycles after the INTACK

Grant Searles webpage http://searle.hostei.com/grant/zx80/zx80nmi.html has some information about this in particular the section near the bottom of the page headed HARDWARE VERIFICATION.

if you fix it correctly you should also see a different behavior when typing LOAD "" when no file has been loaded from the file menu first, instead of the vertical bars you should get the more familiar slanted bars.

HTH Andy
6 x ZX81, 1 x TS1500 , 1 x +3e, 1 x timex 2040 printer, 1 x timex 2020 cassette deck, siclair printer and some spectrum

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest