New release of EightyOne available

Emulator and emulator development specific topics
User avatar
sirmorris
Posts: 2597
Joined: Thu May 08, 2008 4:45 pm
Location: oxon, uk

Re: New release of EightyOne available

Post by sirmorris » Wed Aug 16, 2017 7:02 am

Err which ROM is it? And how are you starting EO? The ROM is found by adding the name from the selection box there to the current working folder. If you start EO by a shortcut and the working folder is set to not be the root of the EO folder then the ROM load will fail.
--=== ZXpand+ ... A more moderner all-in-one upgrade solution for ZX81 ===--
* SD/MMC storage * 32K Hires-capable RAM * AY sound chip * Joystick port * Serial *
* BASIC enhancements - plug & play * Reset button * Auto-boot facility *

User avatar
sirmorris
Posts: 2597
Joined: Thu May 08, 2008 4:45 pm
Location: oxon, uk

Re: New release of EightyOne available

Post by sirmorris » Wed Aug 16, 2017 7:13 am

dr beep wrote:
Sun Aug 13, 2017 8:16 am
I didn't download current version yet, but the "bug" I keep having is when disabling NMI and intrupt in the debugger.
When you undo that EO can hang. I think this is caused when you go to the debugger and you disable the display when EO is in
intruptmode and best is to stop running when undoing.
I've seen this happen. I'm looking into the problem but there doesn't seem to be an obvious cause.
--=== ZXpand+ ... A more moderner all-in-one upgrade solution for ZX81 ===--
* SD/MMC storage * 32K Hires-capable RAM * AY sound chip * Joystick port * Serial *
* BASIC enhancements - plug & play * Reset button * Auto-boot facility *

Moggy
Posts: 1455
Joined: Wed Jun 18, 2008 1:00 pm

Re: New release of EightyOne available

Post by Moggy » Wed Aug 16, 2017 11:25 am

sirmorris wrote:
Wed Aug 16, 2017 7:02 am
Err which ROM is it? And how are you starting EO? The ROM is found by adding the name from the selection box there to the current working folder. If you start EO by a shortcut and the working folder is set to not be the root of the EO folder then the ROM load will fail.
Solved it Charlie.

I usually download things on a downstairs PC bung it on my ZX81's spand card and transfer to upstairs PC.
The short version is card must be on its way out as it has corrupted certain things I've downloaded/added(including 150 ZXM files bummer!) the ROM file must have been one as original download transferred via new card all OK. :oops:

User avatar
siggi
Posts: 738
Joined: Thu May 08, 2008 8:30 am
Location: Dauernheim, Germany
Contact:

Re: New release of EightyOne available

Post by siggi » Mon Aug 28, 2017 10:31 am

What has to be configured to see UDG (e. g. at $2000) on new EO versions? I can see UDG only using old EO versions <= V1
Siggi
My ZX81 web-server: online since 2007
http://zx81-siggi.endoftheinternet.org/index.html

User avatar
Andy Rea
Posts: 1243
Joined: Fri May 09, 2008 1:48 pm
Location: notts UK

Re: New release of EightyOne available

Post by Andy Rea » Mon Aug 28, 2017 12:02 pm

Hi Siggi,

I have been using CHR$ 16 in eightyone, if bit 0 of the i reg = 0 then it's 64 char with the normal 64 inverted chars, if bit 0 of the i reg = 1 then it's 128 char mode

Hth Andy

P.s also some software's use the quiksilva mode
6 x ZX81, 1 x TS1500 , 1 x +3e, 1 x timex 2040 printer, 1 x timex 2020 cassette deck, siclair printer and some spectrum

User avatar
siggi
Posts: 738
Joined: Thu May 08, 2008 8:30 am
Location: Dauernheim, Germany
Contact:

Re: New release of EightyOne available

Post by siggi » Mon Aug 28, 2017 2:00 pm

Hmm, my interceptor does not work: has 512 bytes UDG (copied from Sinclair charset) to $2000

Result is (EOv1.6, ZX81 ed. 2 ROM):
UDG.jpg
UDG.jpg (101.57 KiB) Viewed 244 times
interc-u.p
(12.71 KiB) Downloaded 13 times
:(
Siggi
My ZX81 web-server: online since 2007
http://zx81-siggi.endoftheinternet.org/index.html

User avatar
Andy Rea
Posts: 1243
Joined: Fri May 09, 2008 1:48 pm
Location: notts UK

Re: New release of EightyOne available

Post by Andy Rea » Mon Aug 28, 2017 2:21 pm

working for me, hardware setting are zx81 16k ram sound none, chr$16, highres none, colur none, rom cartrige none, other boxes unchecked, 8 - 16K ram enabled.

Image

regards Andy
6 x ZX81, 1 x TS1500 , 1 x +3e, 1 x timex 2040 printer, 1 x timex 2020 cassette deck, siclair printer and some spectrum

User avatar
siggi
Posts: 738
Joined: Thu May 08, 2008 8:30 am
Location: Dauernheim, Germany
Contact:

Re: New release of EightyOne available

Post by siggi » Mon Aug 28, 2017 2:36 pm

I had WRX enabled!
Now it works as expected.
Thanks
Siggi
My ZX81 web-server: online since 2007
http://zx81-siggi.endoftheinternet.org/index.html

User avatar
zsolt
Posts: 153
Joined: Wed Apr 20, 2011 10:43 am
Location: Fót, Hungary

Re: New release of EightyOne available

Post by zsolt » Tue Aug 29, 2017 10:06 am

Hi,
I also tried the new version and got the same error message (Win10 Home Edition):
Moggy wrote: Every time I boot up Eighty One I get a box that says "ROM file for this system not found go to Options>Hardware>Advanced Settings>ROM File." followed by another box which says "ROM load failed"
However, the ROM file has been loaded and works normally - but writes these false messages. :roll:

Then I tried it on another machine where Symantec Endpoint Protection was installed (Win7 32bit)
EightyOne1v6.png
I got this
EightyOne1v6.png (41.47 KiB) Viewed 205 times
Clicking the Close button the "EightyOne.exe" disappeared. What to do?
Thanks,
Zsolt

User avatar
zsolt
Posts: 153
Joined: Wed Apr 20, 2011 10:43 am
Location: Fót, Hungary

Re: New release of EightyOne available

Post by zsolt » Tue Aug 29, 2017 10:53 am

The latter was solved (i had to allow the file) and works well, but i get those false messages.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest