ZXmore - questions and answers (FAQ)

Any discussions related to the creation of new hardware or software for the ZX80 or ZX81
User avatar
PokeMon
Posts: 2128
Joined: Sat Sep 17, 2011 5:48 pm

ZXmore - questions and answers (FAQ)

Post by PokeMon » Mon Jan 25, 2016 10:14 pm

So here is the thread for all questions and discussions around the ZXmore and technical issues of non running software or hardware.
Feel free to post here what ever you like as long as it is something related to the ZXmore. :mrgreen:

User avatar
PokeMon
Posts: 2128
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Mon Jan 25, 2016 10:34 pm

So here is a nice video you maybe like to discuss or have questions, feel free to ask what you like. 8-)
The used Zeddynet card is an optional interface which can be connected to the expansion port to provide internet access.
http://www.youtube.com/watch?v=e8z8AFU9kK8

vk5hbl
Posts: 6
Joined: Sat Feb 06, 2016 12:43 pm

Re: ZXmore - questions and answers (FAQ)

Post by vk5hbl » Mon Feb 08, 2016 12:27 pm

Gday Karl
Greetings from Down Under.

I have received your kit which is very well put together! Well Done.
Unfortunately I have failed to get mine going :(
It powers up but only shows the letter "K"
As seen in the picture. This happens on every switch position.
I can use the keyboard and type also on every position.
I have read through the other thread for fault finding ideas, I have triple checked correct component placement, solder joints, mods under board, correct jumper position.
Bit stuck on what to look for next?
I have a Oscilloscope, Logic probe, frequency counter etc to help.

cheers
Darren

Image
Image
Image

RWAP
Site Admin
Posts: 1230
Joined: Thu May 08, 2008 7:42 am
Location: Stoke-on-Trent, UK
Contact:

Re: ZXmore - questions and answers (FAQ)

Post by RWAP » Mon Feb 08, 2016 1:21 pm

I may be wrong, but what else were you expecting to see, until you load some software onto the machine?

User avatar
PokeMon
Posts: 2128
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Mon Feb 08, 2016 4:19 pm

Hi Darren,

this is with release 1.7 (expecting 1.8 in a few days) only an 8 bit computer supporting ZX80 and ZX81 as BASIC Computer.
You may test following BASIC program to enter:
10 FOR I=0 TO 255
20 PRINT CHR$ I;
30 NEXT I
40 CLS
50 RUN
Usually you use the ZXmore in switch position 0 and choose the other instances by switching with shift-shift 1 and so on.
The manual switch is used for compatibility purposes but do not allow switching instances by software.

You will find the latest software and links to ZXmore and ZX81 here:
http://sinclairzxworld.com/viewtopic.ph ... 907#p18907

There is also a games section or more software links here as well.
You maybe awaiting the CP/M message which is not yet available but probably next month.
There is release 1.8 waiting to be published in a few days (after fixing some serious timing/stack bug) and the ZX Spectrum release 1.9 later this month and the CP/M release in march 2016 (next month) which will be later the final release 2.9.

If you have any more questions, please ask here. Your system seems to be working correctly as what we can see at your pics.

Karl

vk5hbl
Posts: 6
Joined: Sat Feb 06, 2016 12:43 pm

Re: ZXmore - questions and answers (FAQ)

Post by vk5hbl » Tue Feb 09, 2016 3:12 am

RWAP wrote:I may be wrong, but what else were you expecting to see, until you load some software onto the machine?
I thought it should show this screen in at least position 0?
Image

Cheers
Darren

User avatar
PokeMon
Posts: 2128
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Tue Feb 09, 2016 6:10 pm

Yes - this is the screen in position 0, it is correct. ;)

RWAP
Site Admin
Posts: 1230
Joined: Thu May 08, 2008 7:42 am
Location: Stoke-on-Trent, UK
Contact:

Re: ZXmore - questions and answers (FAQ)

Post by RWAP » Tue Feb 09, 2016 6:49 pm

Ah - the point is that the poster does not see this screen - it goes straight to the K cursor, if I understand him correctly...

User avatar
PokeMon
Posts: 2128
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Tue Feb 09, 2016 7:00 pm

Aha - thought the pic was from Darren. What does happen in position 0 exactly ?
Did you check the extra capacitors and jumper settings as read from the manual ?
For a test you could remove IC22 and IC24 (the latches for RAM/ROM switch) to see if it is showing the start screen.
Not sure when you bought exactly the kit - did you maybe check for an additional 47pF capacitor needed at the cpu between pin 27 and pin 29 ?

As in general the board is working with ZX81 this shouldn't be a big issue. Did you try to hold the shift key pressed when powering up in instance 0 for a cold boot ?

vk5hbl
Posts: 6
Joined: Sat Feb 06, 2016 12:43 pm

Re: ZXmore - questions and answers (FAQ)

Post by vk5hbl » Wed Feb 10, 2016 11:44 am

PokeMon wrote:Aha - thought the pic was from Darren. What does happen in position 0 exactly ?
Did you check the extra capacitors and jumper settings as read from the manual ?
For a test you could remove IC22 and IC24 (the latches for RAM/ROM switch) to see if it is showing the start screen.
Not sure when you bought exactly the kit - did you maybe check for an additional 47pF capacitor needed at the cpu between pin 27 and pin 29 ?

As in general the board is working with ZX81 this shouldn't be a big issue. Did you try to hold the shift key pressed when powering up in instance 0 for a cold boot ?

In position 0 it either doesn't boot or intermitantly boots and shows k
Removing IC22 and IC24 it boots every time ok but not showing start screen.
Extra caps and jumpers and 47pf between pin 27 & 29 done and checked

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest