ZX80 porting of Super Micro Chess 1K

Any discussions related to the creation of new hardware or software for the ZX80 or ZX81
User avatar
marste
Posts: 97
Joined: Sun Aug 10, 2014 8:58 pm
Location: Italy
Contact:

Re: ZX80 porting of Super Micro Chess 1K

Post by marste » Mon Apr 10, 2017 11:26 am

For now I'm just using the emulators, but they really behave in a strangely different way among them... :(

Anyway soon I should be able to test also on a real ZX80! :)

Again, just as a test (is the last work in progress from the weekend), how it behaves on a real ZX80 for the attached file?
zx80sm1k.o
(828 Bytes) Downloaded 11 times
It starts? It displays the board? If yes, flickering? How it reacts to the inputs?

For information, what I can see in the emulators:
- in ZEsarUX: it doesn't start
- in No$Zx: it start and moves, but with a bad background for empty squares when processing
- in EightyOne: it start, display without flickering screen (I adjusted some code for it), but moves just one square and everything is wrong when processing (starting wrongly with just one enter)

Thank you!

Moggy
Posts: 1507
Joined: Wed Jun 18, 2008 1:00 pm

Re: ZX80 porting of Super Micro Chess 1K

Post by Moggy » Mon Apr 10, 2017 1:27 pm

Hi Marste.

Tried it on my 80 and no luck I'm afraid.

At first display is good, white makes first move then it behaves like eighty one with no cursor movement.

At this point if you press enter the display corrupts like in the first picture.

I don't know if you are aware of the original ZX81 1k chess has been improved and ported to the ZX80, I have attached it here c/w assembly listing perhaps examining its code could help you somehow?
Attachments
1KCHESS_plus.zip
(60.92 KiB) Downloaded 10 times
SANY0050.JPG
SANY0050.JPG (3.53 MiB) Viewed 275 times
SANY0058.JPG
SANY0058.JPG (3.93 MiB) Viewed 275 times

User avatar
marste
Posts: 97
Joined: Sun Aug 10, 2014 8:58 pm
Location: Italy
Contact:

Re: ZX80 porting of Super Micro Chess 1K

Post by marste » Mon Apr 10, 2017 8:16 pm

Again, EightyOne seems very reliable (and the only one)!!

Regarding the porting very interesting: some posts ago I was trying to find the proper call to read keyboard and update screen, and here it is: CALL $013F!

I've to look better at it, but seems that I can live without all the logic for flicker free and keyboard reading that there is now (loosing just the blinking of the cursor)!...

Next weekend I'll work on it again, in the meantime thank you!

User avatar
chernandezba
Posts: 156
Joined: Tue Mar 11, 2014 3:30 pm

Re: ZX80 porting of Super Micro Chess 1K

Post by chernandezba » Wed Apr 12, 2017 11:13 am

marste wrote:
Mon Apr 10, 2017 11:26 am

- in ZEsarUX: it doesn't start

It does start on ZEsarUX. You only have to go to Settings->Display-> Real video:On
----

ZEsarUX
ZX Second-Emulator And Released for UniX
https://sourceforge.net/projects/zesarux/

User avatar
marste
Posts: 97
Joined: Sun Aug 10, 2014 8:58 pm
Location: Italy
Contact:

Re: ZX80 porting of Super Micro Chess 1K

Post by marste » Sat Apr 15, 2017 9:50 am

chernandezba wrote:
Wed Apr 12, 2017 11:13 am
marste wrote:
Mon Apr 10, 2017 11:26 am
- in ZEsarUX: it doesn't start
It does start on ZEsarUX. You only have to go to Settings->Display-> Real video:On
1)
Sorry, didn't thought about it!
There is a way to save default parameters?
(e.g. I think that real video should be always on, and I have also some other preferences as GUI style - ZX80/81 :), speed, etc)

----

2)
Anyway differences doesn't stop here! (and I suspect EightyOne to be more accurate, but I can be wrong not having the real reference)

As for example this file is loading with showing just [K] cursor in ZesarUX while in EightyOne seems not even starting!
test1.o
(885 Bytes) Downloaded 5 times

Or this other that again is just giving a normal [K] in ZesaurUX while in EightyOne is producing a "?" followed by [L] and [ S ] cursors:
test2.o
(750 Bytes) Downloaded 7 times
...


@Moggy: I know they still do not work, I'm testing the not autorun version ;)

Moggy
Posts: 1507
Joined: Wed Jun 18, 2008 1:00 pm

Re: ZX80 porting of Super Micro Chess 1K

Post by Moggy » Sat Apr 15, 2017 12:48 pm

Ok Marste understood. :D

User avatar
marste
Posts: 97
Joined: Sun Aug 10, 2014 8:58 pm
Location: Italy
Contact:

Re: ZX80 porting of Super Micro Chess 1K

Post by marste » Sat Apr 15, 2017 7:05 pm

@Moggy: this one instead is for you! And for Paul! :)

Just type "RUN" or "GOTO 53" to start. I didn't take care of strenght parameters (and there might be still bugs inside), just now hope is finally moving something also on a real ZX80 (in all emulators do now, even if the initial screen is different among them!)...
Attachments
sm1kzx80.o
(905 Bytes) Downloaded 11 times

Moggy
Posts: 1507
Joined: Wed Jun 18, 2008 1:00 pm

Re: ZX80 porting of Super Micro Chess 1K

Post by Moggy » Sat Apr 15, 2017 9:08 pm

Downloaded and will try all tonight.

great effort Marste :D

Moggy
Posts: 1507
Joined: Wed Jun 18, 2008 1:00 pm

Re: ZX80 porting of Super Micro Chess 1K

Post by Moggy » Sat Apr 15, 2017 9:20 pm

Just a quick report Marste.

The playing logic seems OK.

But the cursor movement doesn't work correctly.

Whenever you press a key to move the cursor it goes whereever it wants to and sometimes with luck it lands on the square you want after hitting the key 5-10 times,when that happens the piece movement seems ok.

The cursor is also invisible on white squares.

User avatar
marste
Posts: 97
Joined: Sun Aug 10, 2014 8:58 pm
Location: Italy
Contact:

Re: ZX80 porting of Super Micro Chess 1K

Post by marste » Sun Apr 16, 2017 3:43 am

Some good news there is: is starting, visualizing screen and even if input seems not going good even moving!...

Regarding cursor, it is not so visible on dark squares since the inverted pattern is very very similar to the standard one (I think you were referring to them). If this is a problem I can change dark square pattern with almost any of the available characters.

The worst is the keys moving behaviour: strange, since I even ad-hoc managed this behaviour adding a cycle waiting to see no key press after each single move, and in the emulators (all of them) seems working!...

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests