ZX81CCP video output for ZX81

Any discussions related to the creation of new hardware or software for the ZX80 or ZX81
Post Reply
User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

ZX81CCP video output for ZX81

Post by PokeMon » Mon Apr 23, 2012 4:48 pm

Well - not a new video output again, I can hear your voice.
I know, there have been many over the years, most of them have the same problem (transistor discoupling for example). The ULA delivers a disturbing noise in the white background which is caused through the ULA itself and even condensators could not stable the internal voltage drop downs when other signals/pins of the ULA working. This normally doesnt disturb the function of logic circuits as all above 2.0 V is treated as high (TTL logic) regardless any peaks on it with some more voltage. But they used the ULA as video output which is a anlog signal and not just interpreted digitally. As the norm uses 1V pp even very low 30mV peaks are visible in the white background as it corresponds to about 5% white level more or less. Can see with your eyes.
IMG_4717k.jpg
IMG_4717k.jpg (119.12 KiB) Viewed 7577 times
Based on a proposal from Bodo Wenzel (which was based on a publication of Chip computer magazine) I developed now an improoved module with open collector logic gates 74LS06 which scan the video output of ULA and recreate the video signal new when digitized first. This will eliminate the noise from the ULA. Additional a back porch is added to the signal regardless the ULA provide one or not (the older one does not). Missing backporch will give a picture with poor contrast and brightness and some of the newer LCD or plasma TV even do not accept those signals (show black screen).

As some people like, I added a dip switch for choosing either normal video mode (black characters on white screen) or inverted (white characters on a black screen). Here is the schematic.
ZX81VidBasic.gif
ZX81VidBasic.gif (15.42 KiB) Viewed 7583 times
The top 2 inverters are used for the video content (pixel data).
The middle 2 inverters are generating sync signal.
The last 2 inverters are for creating the back porch with a simple r/c combination, triggered from sync signal.

It adds a quite good picture on all tested screens.
You can see more sample pics of video here:
http://forum.tlienhard.com/phpBB3/viewt ... ?f=2&t=651

Integration can be made very easy due to a small SMD board (onesided) which can be fixed in the case with just a small tape:
IMG_4721k.jpg
IMG_4721k.jpg (313.27 KiB) Viewed 7579 times
And the good news:
It''s now available for sale on www.sellmyretro.com for GBP 9.90 completely soldered, tested and pre-adjusted.
Have to be re-adjusted for newer ULA / issue 3 board.

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZX81CCP video output for ZX81

Post by PokeMon » Mon Aug 06, 2012 11:42 pm

So the good news:
The new version with Standby Sync Generator is finished (development).
I tested it with 2 different TVs. They are not disconnecting / switch off / change channel when ZX81 running in FAST mode.
So the screen is just white. So it does nearly the same what the old board did (crystal clear picture output) + standby sync.
The sync is generated for horizontal and vertical period.

The board has 2 trimmers for adjusting to ULA voltage level, needs 5V from Zeddy but only spare power consumption of approx. 20mA.
I think the old board could have 60-80mA depending on version you use.
And it has 2 switches for inverting the video signal (white char on black screen) and for switch off the sync generator (for maybe any incompatibility).
And the new board is a little bit smaller than the old one but has some more active components.
I think costs will be nearly the same.
ZX81VIDAS.jpg
ZX81VIDAS.jpg (82.05 KiB) Viewed 6548 times

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZX81CCP video output for ZX81

Post by PokeMon » Mon Aug 06, 2012 11:46 pm

And this will be the board, SMD, 27.5 x 21 mm ( about 1.1 x 0.8 inches)
There is a new name, ZX81SCP instead of ZX81CCP (Synced Clear Picture)
ZX81SCP.gif
ZX81SCP.gif (17.73 KiB) Viewed 6545 times
Paul from german forum is testing it for me at home too.
If all will be okay it could be available in about 4 weeks.
If anyone interested. ;)

User avatar
sirmorris
Posts: 2697
Joined: Thu May 08, 2008 4:45 pm
Location: oxon, uk

Re: ZX81CCP video output for ZX81

Post by sirmorris » Tue Aug 07, 2012 8:30 am

Damn right I am! I'll have 2 please! :D
--=== ZXpand+ ... A more moderner all-in-one upgrade solution for ZX81 ===--
* SD/MMC storage * 32K Hires-capable RAM * AY sound chip * Joystick port * Serial *
* BASIC enhancements - plug & play * Reset button * Auto-boot facility *

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZX81CCP video output for ZX81

Post by PokeMon » Tue Aug 07, 2012 12:14 pm

No problem. I think I take 20 as minimum anyway.
But last time the 35 boards were finished fast.
So better ask first what people want or need. ;)

User avatar
sirmorris
Posts: 2697
Joined: Thu May 08, 2008 4:45 pm
Location: oxon, uk

Re: ZX81CCP video output for ZX81

Post by sirmorris » Tue Aug 07, 2012 12:24 pm

One question - you may have answered this already - what happens during SAVE/LOAD from tape??

C
--=== ZXpand+ ... A more moderner all-in-one upgrade solution for ZX81 ===--
* SD/MMC storage * 32K Hires-capable RAM * AY sound chip * Joystick port * Serial *
* BASIC enhancements - plug & play * Reset button * Auto-boot facility *

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZX81CCP video output for ZX81

Post by PokeMon » Tue Aug 07, 2012 2:12 pm

Well - that is an interesting question. I don't know. :mrgreen:
I think through load the output of the ULA is unused.
I don't know about SAVE.
Can not test now because Paul has my board now. ;)

Technically the sync generator does start when ULA output is hold low (sync level) for about 20ms. Any high pulse on ULA would clear this timer period and stop sync generator depending a bit on length of that pulse.

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZX81CCP video output for ZX81

Post by PokeMon » Tue Aug 07, 2012 3:36 pm

It would be possible to detect horizontal sync signals out of specification (< 32us or > 96us for example) instead of no sync for 20ms.
The 20ms second timeout was the easiest way for me to adapt.
But maybe not needed. Lets wait what Paul says. :shock:

User avatar
questarian
Posts: 49
Joined: Sun Jun 17, 2012 8:40 pm

Re: ZX81CCP video output for ZX81

Post by questarian » Wed Aug 08, 2012 5:16 am

Excellent ! I'd be interested in at least 2 as well! :)

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: ZX81CCP video output for ZX81

Post by PokeMon » Wed Aug 08, 2012 12:00 pm

sirmorris wrote:One question - you may have answered this already - what happens during SAVE/LOAD from tape??

C
I looked in the Sincair manual and found, that there is a visible pattern on screen during SAVE and (!) LOAD.
The question is about the level - if it's just black and white or if it's generating sync pulses as well.
Time to take the oscilloscope to view the signals. ;)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests