My zx80/zx81 clon is working

Discussions about Sinclair ZX80 and ZX81 Hardware
RWAP
Site Admin
Posts: 1235
Joined: Thu May 08, 2008 7:42 am
Location: Stoke-on-Trent, UK
Contact:

Re: My zx80/zx81 clon is working

Post by RWAP » Tue Oct 24, 2017 2:23 pm

Looks nice - although anyone else spotted there is only one W button (it is upside down!) and 2 rivets used instead of the other 2 W buttons....

wilco2009
Posts: 30
Joined: Sat Feb 04, 2017 11:03 am

Re: My zx80/zx81 clon is working

Post by wilco2009 » Tue Oct 24, 2017 2:59 pm

RWAP wrote:
Tue Oct 24, 2017 2:23 pm
Looks nice - although anyone else spotted there is only one W button (it is upside down!) and 2 rivets used instead of the other 2 W buttons....
Thank you for your comments. I have not access to any zx80 with the rivets/W buttons, and it is really dificult to find any picture of a complete zx80 in the internet.

My assumption was that rivets were used in the original one, inserted from above to facilitate their insertion / extraction.
In any case, it is easy to change.

User avatar
sirmorris
Posts: 2698
Joined: Thu May 08, 2008 4:45 pm
Location: oxon, uk

Re: My zx80/zx81 clon is working

Post by sirmorris » Tue Oct 24, 2017 3:03 pm

I like the red board. Most clones try to replicate the look of the original board and while I appreciate this I also think the red board is more ... honest! :D
--=== ZXpand+ ... A more moderner all-in-one upgrade solution for ZX81 ===--
* SD/MMC storage * 32K Hires-capable RAM * AY sound chip * Joystick port * Serial *
* BASIC enhancements - plug & play * Reset button * Auto-boot facility *

wilco2009
Posts: 30
Joined: Sat Feb 04, 2017 11:03 am

Re: My zx80/zx81 clon is working

Post by wilco2009 » Tue Oct 24, 2017 3:18 pm

In my case, it is not only a zx80 clone, then it is not possible to replicate exactly route of the board, and due to it, there are not reason to make a exact replication of the board. And the board in red is nice :D

User avatar
mhudson52
Posts: 45
Joined: Tue Sep 27, 2016 1:17 am

Re: My zx80/zx81 clon is working

Post by mhudson52 » Tue Oct 24, 2017 5:15 pm

Impressive! Great job!
TS 1000 bought in 1982

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: My zx80/zx81 clon is working

Post by PokeMon » Tue Oct 24, 2017 8:33 pm

Good job. It has more chips - did you integrate the NMI generator ?
So it is not a plain ZX80 ? ;)

User avatar
gammaray
Posts: 288
Joined: Sun Apr 17, 2016 1:44 am
Location: Texas

Re: My zx80/zx81 clon is working

Post by gammaray » Tue Oct 24, 2017 9:04 pm

For longest time I thought the rise in the top of the ZX80 case was where the rampack would insert into the bus... :?

If it was redesigned maybe this would be an aesthetic improvement. Put power and video on left side and ear mic on the right.
Last edited by gammaray on Thu Nov 23, 2017 10:29 pm, edited 1 time in total.
Finish what you start. Truth is over the mountaintop or six feet under.
4 x TS1000, 2 x TS1500 , 2 x timex 2040 printer, 1/2 x timex 2020 cassette deck, ZXPAND, ZeddyNET, ZXBlast..., unfinished Spectrum...Still no life!

wilco2009
Posts: 30
Joined: Sat Feb 04, 2017 11:03 am

Re: My zx80/zx81 clon is working

Post by wilco2009 » Tue Oct 24, 2017 10:12 pm

PokeMon wrote:
Tue Oct 24, 2017 8:33 pm
Good job. It has more chips - did you integrate the NMI generator ?
So it is not a plain ZX80 ? ;)
Not, it is something more, you can convert it in a zx81 with the selector in the bottom side. I think you will like the next pictures. ;)

Image

Image

User avatar
PokeMon
Posts: 2171
Joined: Sat Sep 17, 2011 5:48 pm

Re: My zx80/zx81 clon is working

Post by PokeMon » Tue Oct 24, 2017 10:38 pm

*LIKE* :mrgreen:

User avatar
1024MAK
Posts: 1803
Joined: Mon Sep 26, 2011 9:56 am
Location: Looking forward to summer in Somerset, UK...

Re: My zx80/zx81 clon is working

Post by 1024MAK » Fri Oct 27, 2017 1:59 pm

@wilco2009 - excellent work 8-) :D

Mark

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 2 guests