Search found 73 matches

by albertusj
Tue Dec 08, 2020 12:25 pm
Forum: SALES
Topic: ZX80 replica main board checking for interest
Replies: 5
Views: 1168

Re: ZX80 replica main board checking for interest

May I ask what the community think a fair price would be?
by albertusj
Tue Dec 08, 2020 10:14 am
Forum: SALES
Topic: ZX80 replica main board checking for interest
Replies: 5
Views: 1168

Re: ZX80 replica main board checking for interest

Yeah, on second thought you're right. Thanks.
by albertusj
Mon Dec 07, 2020 12:32 pm
Forum: SALES
Topic: ZX80 replica main board checking for interest
Replies: 5
Views: 1168

ZX80 replica main board checking for interest

I'm trying to see what the level of interest would be in my ZX80 replica board.
Image
Image
Image

I'm looking to get ~£300

Any interest?
by albertusj
Wed May 13, 2020 6:31 pm
Forum: ZX Spectrum Lounge
Topic: Photo of my TC-2048
Replies: 9
Views: 14209

Re: Photo of my TC-2048

What's the number on that big SCLD chip in the middle?
by albertusj
Wed May 13, 2020 6:27 pm
Forum: ZX Spectrum Lounge
Topic: Photo of my TC-2048
Replies: 9
Views: 14209

Re: Photo of my TC-2048

gorgeous machine!
by albertusj
Wed May 13, 2020 5:28 pm
Forum: ZX Spectrum Lounge
Topic: Timex Sinclair 2048 replica!
Replies: 3
Views: 9124

Re: Timex Sinclair 2048 replica!

:o Nice work!
by albertusj
Tue May 12, 2020 11:07 am
Forum: Development
Topic: New ZX80 cases
Replies: 27
Views: 18362

Re: New ZX80 cases

I am interested and will take two at about $60 - $70 each.
by albertusj
Tue Dec 10, 2019 8:40 pm
Forum: Hardware
Topic: ZX80 no "K" prompt
Replies: 12
Views: 2751

Re: ZX80 no "K" prompt

Check out the second build at the bottom of my web page:

http://www.myprius.co.za/ZX80.htm
by albertusj
Tue Dec 10, 2019 10:59 am
Forum: Hardware
Topic: ZX80 no "K" prompt
Replies: 12
Views: 2751

Re: ZX80 no "K" prompt

C11 was missing! I forgot to put in one tiny 47pF capacitor. I'm such an idiot!

It gives a "K" prompt now. Thanks, everybody for trying to help.

:-)
by albertusj
Mon Dec 09, 2019 3:47 pm
Forum: Hardware
Topic: ZX80 no "K" prompt
Replies: 12
Views: 2751

Re: ZX80 no "K" prompt

I plugged in a known working RAM pack (which disables onboard RAM) and also swapped in a known working CPU to no avail. :|