Search found 92 matches

by msch
Wed May 13, 2020 12:59 am
Forum: Announcements
Topic: unscheduled downtime
Replies: 0
Views: 439

unscheduled downtime

Today (Tue May 12, 2020) we had an unscheduled downtime due to technical problems in the data center and the recovery process took longer than expected. Please excuse the inconvenience.
by msch
Sat Apr 25, 2020 9:53 am
Forum: Z88
Topic: Welcome Z88 Users
Replies: 5
Views: 521

Re: Welcome Z88 Users

Sorry Rich, this sub-forum is intended as a replacement for the old z88world.com forums because of the low level of postings in the old forums.
At a later time I will migrate the old postings to this forums.
by msch
Wed Apr 22, 2020 10:20 am
Forum: Announcements
Topic: New Z88 forums
Replies: 0
Views: 599

New Z88 forums

New Discussion forums for users of the Cambridge Z88 Portable Computer:
viewforum.php?f=24
Replacement for "old" z88world.com forums.
Have fun!
by msch
Wed Apr 22, 2020 10:14 am
Forum: Z88
Topic: Welcome Z88 Users
Replies: 5
Views: 521

Welcome Z88 Users

New Discussion forums for users of the Cambridge Z88 Portable Computer. Replacement for "old" z88world.com forums. Have fun!
by msch
Mon Apr 20, 2020 3:19 pm
Forum: Announcements
Topic: Forums Relocation
Replies: 5
Views: 20360

Re: Forums Relocation

Software updated to latest version.
by msch
Wed Dec 18, 2019 7:34 am
Forum: Development
Topic: New ZX80 cases
Replies: 26
Views: 4900

Re: New ZX80 cases

Please keep us informed here because some people do not want to use facebook. A former member of the german ZX Team, Ali Schams, made some replica cases and I own three of them. You can see the cases in this video (made on the ZX Team Meeting in 2014): https://www.youtube.com/watch?v=tDx58BozFEU Unf...
by msch
Tue Dec 10, 2019 4:37 pm
Forum: Hardware
Topic: Why did sinclair not add an option for NTSC output
Replies: 5
Views: 2530

Re: Why did sinclair not add an option for NTSC output

1024MAK wrote:
Tue Dec 10, 2019 5:48 am
Sinclair did make a NTSC version of the ZX Spectrum,
see here:
https://faqwiki.zxnet.co.uk/wiki/NTSC_Spectrum
by msch
Tue Dec 10, 2019 4:32 pm
Forum: Hardware
Topic: ZX80 no "K" prompt
Replies: 12
Views: 1844

Re: ZX80 no "K" prompt

albertusj wrote:
Tue Dec 10, 2019 10:59 am
C11 was missing! I forgot to put in one tiny 47pF capacitor.
:roll: :mrgreen:

Great that it is running now.
by msch
Mon Dec 09, 2019 3:44 pm
Forum: Hardware
Topic: ZX80 no "K" prompt
Replies: 12
Views: 1844

Re: ZX80 no "K" prompt

I would say CPU or RAM. Do You have another Z80 to swap?