Search found 8 matches

by fizzyade
Fri Jul 13, 2018 12:17 pm
Forum: SALES
Topic: ZX81 ULA
Replies: 76
Views: 18687

Re: ZX81 ULA

The ZX81 I purchased did indeed turn out to have a faulty ULA! Was so happy when this replacement bought the "K" to the screen!

Many thanks Andy!
by fizzyade
Thu Jul 12, 2018 10:33 pm
Forum: Hardware
Topic: ZX81 Repair (No video for starters!)
Replies: 7
Views: 1492

Re: ZX81 Repair (No video for starters!)

Yeah, i’ll Probably reunite the machine with an original from Ian at some point.

Happy to see it come back to life, even happier when the keyboard worked without issue as well!
by fizzyade
Thu Jul 12, 2018 2:33 pm
Forum: Hardware
Topic: ZX81 Repair (No video for starters!)
Replies: 7
Views: 1492

Re: ZX81 Repair (No video for starters!)

It's the ULA.

I noticed that IOREQ wasn't pulsing, swapped out to Andys ULA and hey presto pulsing.

Looked at the video signal in more detail and there was indeed modulation (very noisy signal), held a composite cable against the modulator case and signal and whoosh a "K" on the TV.
by fizzyade
Thu Jul 12, 2018 9:53 am
Forum: Hardware
Topic: ZX81 Repair (No video for starters!)
Replies: 7
Views: 1492

Re: ZX81 Repair (No video for starters!)

The video generation is done by the Z80 CPU and the ULA working together. If the CPU is not running, for whatever reason, the ULA will not and cannot produce a valid video signal. So we start with testing the Z80 pins with either a logic probe, a logic analyser or a oscilloscope. What are /RESET, /...
by fizzyade
Thu Jul 12, 2018 12:09 am
Forum: Welcome Area
Topic: Hello
Replies: 4
Views: 1280

Re: Hello

1024MAK wrote:
Wed Jul 11, 2018 11:36 pm
Hello Ade

Welcome to our forum :D

Mark
Recognise you from stardot! I think I sent you one of Simon’s cartridge kits that I put the bits together for.
by fizzyade
Thu Jul 12, 2018 12:08 am
Forum: Hardware
Topic: ZX81 Repair (No video for starters!)
Replies: 7
Views: 1492

Re: ZX81 Repair (No video for starters!)

I’ll have a check in the morning, address lines were going as was RD, i’ll Prove them specifically tomorrow.

Doesn’t the ULA produce the modulation independant of the CPU? (I.e it halts the CPU and does a read of the ram).

Thanks for the response. New to the ZX81.
by fizzyade
Wed Jul 11, 2018 5:39 pm
Forum: Welcome Area
Topic: Hello
Replies: 4
Views: 1280

Hello

Hi,

I've been frequenting various spectrum groups and BBC groups as these are the machines that I grew up with and have a huge amount of love for!

Just got a ZX81 which I am trying to repair, hence why I'm here!

Been a lurker for a while but thought I'd better sign up.

Ade
by fizzyade
Wed Jul 11, 2018 5:11 pm
Forum: Hardware
Topic: ZX81 Repair (No video for starters!)
Replies: 7
Views: 1492

ZX81 Repair (No video for starters!)

Hi, I recently obtained my first ZX81! That's the good news, the bad news is that it doesn't work. I've probed around the board at various stages, I'm seeing a 3.25Mhz oscillation going to the Z80 which appears to be generating reads and addresses. The oscillator input on the ULA appears to be at 3v...