Search found 225 matches

by Erm
Sun Jul 16, 2023 2:35 pm
Forum: ZX Spectrum Lounge
Topic: Greaseweazle for +3 disks - help
Replies: 1
Views: 5772

Re: Greaseweazle for +3 disks - help

Fixed it. My adapter ribbon cable was incorrect for the Greaseweazle.
by Erm
Fri Jul 14, 2023 9:36 pm
Forum: ZX Spectrum Lounge
Topic: Greaseweazle for +3 disks - help
Replies: 1
Views: 5772

Greaseweazle for +3 disks - help

Has anyone got any experience using a Greaseweazle to image original Spectrum +3 3" disks? I have the cabling sorted, ribbon adapter, 5v/12v power connections switched and a known working 3" drive attached to my Greaseweazle and a modern Win10 PC. I'm using GreaseweazleGUI v2.115 and the 'Read From ...
by Erm
Mon Jun 05, 2023 10:58 pm
Forum: Z88
Topic: How do you add/run an app?
Replies: 7
Views: 6130

Re: How do you add/run an app?

I managed to get it working for long enough to move the zetriz files across and have installed that, so that's something. I removed a battery and am now just running off the PSU, but Lemmings didn't install (seemed to work, but nothing appeared on the menu). And now the file transfer is shit again. ...
by Erm
Mon Jun 05, 2023 9:37 pm
Forum: Z88
Topic: How do you add/run an app?
Replies: 7
Views: 6130

Re: How do you add/run an app?

Spoke too soon, it's now totally unreliable again and I can't connect/move files :(
by Erm
Mon Jun 05, 2023 9:14 pm
Forum: Z88
Topic: How do you add/run an app?
Replies: 7
Views: 6130

Re: How do you add/run an app?

Blimey, I solved the dodgy connection with EazyLink2! I was running it off a generic 6v PSU and I suppose it must have been providing noisy voltage. Fresh batteries in and now it works.
by Erm
Mon Jun 05, 2023 8:16 pm
Forum: Z88
Topic: How do you add/run an app?
Replies: 7
Views: 6130

Re: How do you add/run an app?

Erm, yes. They have an .app extension and are referred to as applications, so despite me being old enough to normally use 'program' or even 'executable/exe', I thought it would be more correct to call them apps. Hi, Go to filer, []F, mark the file .app, (enter) and then press INDEX and say yes to in...
by Erm
Mon Jun 05, 2023 1:10 pm
Forum: Z88
Topic: How do you add/run an app?
Replies: 7
Views: 6130

How do you add/run an app?

Erm, this might be really obvious but I cannot find an intuitive way to run an .app on my Z88. Google doesn't seem to be as useful as it once was, or is it just me? Hardware: Z88 with 512k internal flash. Running Eazylink I got the Lemmings files over to my RAM.0. There are files with .app, .ap0 and...
by Erm
Mon Jan 10, 2022 10:15 pm
Forum: Hardware
Topic: ZX80 troubleshoot /HALT is high
Replies: 4
Views: 1764

Re: ZX80 troubleshoot /HALT is high

Some scope stills. These Address lines are rapid and look 'normal' (to me), like this: AddressLinesScope1.jpg These Address lines are the less frequent, like this (or similar with the solid line high, and it dipping down to gnd instead of up to 5v): AddressLinesScope2.jpg Data lines all look very si...
by Erm
Mon Jan 10, 2022 9:02 pm
Forum: Hardware
Topic: ZX80 troubleshoot /HALT is high
Replies: 4
Views: 1764

Re: ZX80 troubleshoot /HALT is high

Oh yes, one other thing I did notice that may not be significant but I'll mention it. When testing the 74LS05 chips in my XGecu/Minipro they always fail with the 7405 option but pass with the option labelled 74HC05(OD). I expect that's normal and is just the way the device measures/handles the level...
by Erm
Mon Jan 10, 2022 8:14 pm
Forum: Hardware
Topic: ZX80 troubleshoot /HALT is high
Replies: 4
Views: 1764

Re: ZX80 troubleshoot /HALT is high

Thanks for taking the time to reply Mark, I really hope I can get this one going. If /HALT is active (this is an output pin on a Z80), it indicates that the Z80 has encountered a HALT instruction. If interrupts are NOT enabled, or the /INT input is faulty, the Z80 will just execute NOP (no operation...