Search found 367 matches

by RetroTechie
Wed Jun 19, 2019 5:04 am
Forum: Hardware
Topic: Unusual PSU
Replies: 4
Views: 161

Re: Unusual PSU

I've seen several marked "EURO 1400" as well. Not sure if other values like 1200 or 700 were also used in combination with that. Iirc some of those supplies had the same transformer inside, just different value capacitors (to 'upgrade' a "1200" to "1400" or similar). And/or same as some Spectrum psu...
by RetroTechie
Wed Jun 19, 2019 4:44 am
Forum: Hardware
Topic: French FrankenZX81, unique?
Replies: 14
Views: 265

Re: French FrankenZX81, unique?

Those RAM boards could very well be off-the-shelf RAM expansions. With 16KB on each, I suspect one of those is modified to fill some other memory area than the 4000-7FFFh for a normal 16K pack. That last expansion board is certainly some custom (or at least low-volume) job. Wire-wrap no less. Great ...
by RetroTechie
Mon Jun 10, 2019 5:23 pm
Forum: Hardware
Topic: HELP i was trying to replace caps now i have issues!
Replies: 2
Views: 389

Re: HELP i was trying to replace caps now i have issues!

Rule #1 of modding: check that machine works before modifying anything. Rule #2 of modding: if after that you find machine doesn't work anymore, it will be because of whatever was modified just now . Double-check, triple-check, or undo if necessary. Sure there's ESD, pcb tracks where a crack develop...
by RetroTechie
Sat Jun 08, 2019 8:38 pm
Forum: Hardware
Topic: White screen and no cursor at all
Replies: 38
Views: 1637

Re: White screen and no cursor at all

Isn't that mini-pcb supposed to go into the modulator can? :? (after you rip its contents out). That would very much tidy up the wiring since all signals / power supply you need is right there.
by RetroTechie
Sun May 12, 2019 10:52 pm
Forum: Hardware
Topic: White screen and no cursor at all
Replies: 38
Views: 1637

Re: White screen and no cursor at all

(..) although I'm not very condifent with my probe. Just poke it into some other apparatus. There's a cpu in everything these days! :lol: (and clock oscillators that go with it) The resistor that you mention is R3 that is marked as "not used" in the electronic schemas No it's not. Afaict from the p...
by RetroTechie
Sun May 12, 2019 2:01 pm
Forum: Hardware
Topic: White screen and no cursor at all
Replies: 38
Views: 1637

Re: White screen and no cursor at all

After testing with a digital probe I've found that the CLOCK signal on the pin 14 of the ULA is not present, its state is LOW and no PULSE. That would indicate a problem with the ceramic resonator, surrounding passive components, or ULA. But have a look at the board: there's some bodge resistor the...
by RetroTechie
Mon Apr 22, 2019 3:05 pm
Forum: Hardware
Topic: Composite mod done Zx81 great picture but somethkng is wrong
Replies: 14
Views: 655

Re: Composite mod done Zx81 great picture but somethkng is wrong

I notice it's true the ULA does still gets a bit hot, but only in the center of the chip which surprised me given i have replaced the regulator. Hmm yeah, center of the chip is where the heat gets released... ;) The ULA's dissipation is not changed by a regulator replacement, only the temperature o...
by RetroTechie
Sun Apr 21, 2019 10:50 pm
Forum: Hardware
Topic: Composite mod done Zx81 great picture but somethkng is wrong
Replies: 14
Views: 655

Re: Composite mod done Zx81 great picture but somethkng is wrong

That light-colored band on the electrolytic capacitor (facing resistor), is that the band indicating "-" (minus)? If so, you've got cap reversed. :x Most positive voltage will be on the transistor/resistor side, lower voltage on RCA center pin (monitor input). So + of capacitor goes onto resistor/tr...
by RetroTechie
Wed Apr 17, 2019 5:52 pm
Forum: Hardware
Topic: Zx81 from death to life??
Replies: 17
Views: 823

Re: Zx81 from death to life??

@RS232: re-read my earlier post. You need to DOUBLE-CHECK modifications done since last working config. Looking closer at the pics, I noted: video signal comes from ULA (pin 16). Where to? Appears to be going nowhere. If indeed the case, then it logically follows that screen info doesn't make it to ...
by RetroTechie
Mon Apr 15, 2019 9:04 am
Forum: Hardware
Topic: Zx81 from death to life??
Replies: 17
Views: 823

Re: Help my zx81 mod has gone wrong!! 8 bit death

I think i cracked it i tried one of these diodes and a 1W-100R resistor no idea if it means 100oms (..) Brown-black-brown = 1, 0, x 10^1 = 100 Ohm indeed. Doing mods like this, one should a) know this , and b) preferably verify using a multimeter before putting the part in. Anyway - good job! :D Di...