Search found 124 matches

by nama
Sun Sep 03, 2017 6:29 am
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Me again,
I tried 2 things:
1) plugged in the ZXpand. It looked perfect...

IMG_6159.JPG
IMG_6159.JPG (29.1 KiB) Viewed 1741 times
2) plugged in the keyboard with no ZXpand...
IMG_6160.JPG
IMG_6160.JPG (28.43 KiB) Viewed 1741 times
by nama
Sun Sep 03, 2017 5:34 am
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Hi guys, So I connected the ROM CS line to the 680 Ohm resistor instead of directly to the ROM pin 20. This helped, now I can connect GND to the 74LS32 and still get the cursor. In fact the 'K' cursor first appears perfectly formed, then after a few seconds pixels start to flicker off. Strangely thi...
by nama
Sun Sep 03, 2017 3:55 am
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Yes, very strange indeed.
Here is a pic of the cursor without the GND line attached to the 74LS32.
IMG_6156.PNG
IMG_6156.PNG (115.72 KiB) Viewed 1752 times
Sometime it looks more formed than this, and other times worse.

As I mentioned previously, if I connect the GND line up then the screen become blank again.

Phil
by nama
Sun Sep 03, 2017 12:12 am
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Just racing out the door, but wanted to get this out there quickly. Firstly thanks for the great ideas. I quickly built Andy's circuit using jumper wires, and lifting pin 13 in the ULA. At first it didn't work...still a blank white screen. Then I accidentally knocked the GND wire off the 7432 and I ...
by nama
Sat Sep 02, 2017 1:51 am
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Hi Andy,
Can you briefly explain how that would be hooked up?

Cheers

Philip
by nama
Fri Sep 01, 2017 10:24 pm
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Thanks again for the reply.
Would something like this work?
Screen Shot 2017-09-02 at 8.15.55 AM.jpg
Screen Shot 2017-09-02 at 8.15.55 AM.jpg (41.99 KiB) Viewed 1269 times
One question.
If the issue is the CS line, would installing the ZXpand (with it's own copy of the ROM) fix this, or does it still rely on the CS line from the ULA for it to work?

Cheers
by nama
Fri Sep 01, 2017 1:33 pm
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Hi guys, I didn't see your last replies as I was busy pulling the ULA. Dropped in a socket and installed the ULA from my junker ZX81. It Works!!! (Actually I first tried the dead ULA in the junker machine first, just to be safe and sure.) It's a little saddening to see my old ULA dead and that with ...
by nama
Fri Sep 01, 2017 10:24 am
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

ROM removed socketed and replaced with another from a spare machine. Unfortunately there was no change :-(

What's next... The ULA?
by nama
Fri Sep 01, 2017 9:14 am
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Hi guys,
Well, when I probed D7 with the logic probe it literally showed no high, low or pulsing lights. I looked at the resistor and that looked within spec... Or at least the same as all the other for D0 to D7.
Strange.

I'll whip out the ROM and try another.

Cheers

Phil
by nama
Thu Aug 31, 2017 11:51 pm
Forum: Hardware
Topic: White screen of death
Replies: 33
Views: 5774

Re: White screen of death

Hi guys, Thanks for all the great insights. To answer some of your question about the ROM, it looks like a ceramic Motorola masked ROM (basically like a ceramic EPROM without the window). Has ZCM38818C written on it. I also tried putting a 16K RAM pack in, but the results were the same...white scree...