HRG-MS Troubles

Discussion about ZX80 / ZX81 Software
Post Reply
User avatar
gammaray
Posts: 586
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

HRG-MS Troubles

Post by gammaray » Fri Sep 23, 2016 1:32 am

With ZXPAND 2.3 ...

Tried using HRG-MS loading HRG-16K.P and HRG-64K.P and then demo16.p and demo64.p.

Most banks of "demo" graphics turned out garbage.

Options Tried
LOAD "HRG-*.p" LOAD "demo*.p" LOAD "demo*.p:X"
16K X X X

64K X X X

Any useful comments? :roll:
5-TS1000,UK ZX81<-Sheelagh, US ZX81, 2-TS1500/KDLX , 3-TS2040 printer, 2-TS2020 cassette decks, ZXPAND+AY, ZeddyNET, ZXBlast, UDG, ZX8CCB, AERCO, BUILDS/REPAIRS ZX Spectrum, ZX80 Minstrel, ZXMAX48 v1 v2, 2-TS-2068, ROM, 16kRAM

sirmorris
Posts: 2813
Joined: Thu May 08, 2008 5:45 pm

Re: HRG-MS Troubles

Post by sirmorris » Fri Sep 23, 2016 9:54 pm

Is that a colon or semicolon? You need a semicolon before X. If it is already a semicolon... :?

User avatar
gammaray
Posts: 586
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

Re: HRG-MS Troubles

Post by gammaray » Fri Sep 23, 2016 11:22 pm

It was a semicolon on the ZX but picking it up by the tail to put on this BB it came off.

I noticed that ZX # 1 had display glitches.

So I switched to ZX #2 and still had problemos similar but different.

Going to try emulator and other ZX s...

Maybe the .P has been corrupted. I am not getting the same RAMTOP as listed in the instructions...
64k - 30144 instead of 30160
Last edited by gammaray on Sun Sep 25, 2016 3:55 am, edited 1 time in total.
5-TS1000,UK ZX81<-Sheelagh, US ZX81, 2-TS1500/KDLX , 3-TS2040 printer, 2-TS2020 cassette decks, ZXPAND+AY, ZeddyNET, ZXBlast, UDG, ZX8CCB, AERCO, BUILDS/REPAIRS ZX Spectrum, ZX80 Minstrel, ZXMAX48 v1 v2, 2-TS-2068, ROM, 16kRAM

User avatar
PokeMon
Posts: 2225
Joined: Sat Sep 17, 2011 6:48 pm

Re: HRG-MS Troubles

Post by PokeMon » Sat Sep 24, 2016 12:51 pm

I don't know the capabilities of ZXpand very well and not sure what are you doing there (loading both drivers, 16k and 64k) ? Why ?

I use the MS HRG stuff from Mathias Swatosch on my ZXmore and they run very well (HRG-16k.p and Demo16.p for example). They have to be started loaded one after each other (load driver, run, load application, run) as the driver does change RAMTOP when started first.
I don't know the loading capabilities from ZXpand, if this is assured with your command. ;)

User avatar
mrtinb
Posts: 925
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: HRG-MS Troubles

Post by mrtinb » Sat Sep 24, 2016 1:16 pm

There seems to be a nice manual here: http://www.swatosch.de/zx81/doku-en.pdf
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
mrtinb
Posts: 925
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: HRG-MS Troubles

Post by mrtinb » Sat Sep 24, 2016 1:20 pm

This page states:
Here are the key features of this software:
  • compatible with ZXpand hardware
  • program installs itself over RAMTOP, needs no REM line with machine-code in the user program
  • hotkeys for switching view from graphic bank to text screen and vice versa (even if program is running)
  • hotkeys for switching view to different graphic banks (if more than 16k RAM, even if program is running)
  • hotkey for immediate printout of the screen (even if program is running)
  • 256 x 192 pixel
  • easy interface to ZX81-Basic
  • interface to other machine-code programs to use the graphics
  • multiple graphic-banks if you have more than 16k RAM
  • functions for setting pixels, drawing lines or boxes etc.
  • ZX81-graphics with text and HiRes-graphic overlaid
  • ZX-printer and Seikosha GP-50S supported (Alphacom 32 or Timex Printer should work also)
  • 127 user definable graphics or characters (UDG)
  • manual in English and German language
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
gammaray
Posts: 586
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

Re: HRG-MS Troubles

Post by gammaray » Sun Sep 25, 2016 3:49 am

They have to be started loaded one after each other (load driver, run, load application, run) as the driver does change RAMTOP when started first.
"Yes. You are correct Sirr!"

Actually I am using TS1000eses. Would this affect ...anything...?

My RAMTOP is not identical to the instructions after loading driver.

Hmmm... Going to have to modify a regular ts1016 rampack now and test without Spandex.

BB removed formatting on:
Options Tried
LOAD "HRG-*.p" -> LOAD "demo*.p" or LOAD "demo*.p:X"
16K X X X

64K X X X

X - option did not work...
5-TS1000,UK ZX81<-Sheelagh, US ZX81, 2-TS1500/KDLX , 3-TS2040 printer, 2-TS2020 cassette decks, ZXPAND+AY, ZeddyNET, ZXBlast, UDG, ZX8CCB, AERCO, BUILDS/REPAIRS ZX Spectrum, ZX80 Minstrel, ZXMAX48 v1 v2, 2-TS-2068, ROM, 16kRAM

User avatar
PokeMon
Posts: 2225
Joined: Sat Sep 17, 2011 6:48 pm

Re: HRG-MS Troubles

Post by PokeMon » Sun Sep 25, 2016 12:40 pm

Normally the driver refuses to load when RAMTOP is not set correctly - this is tested first when typing RUN to load.
The actual version on his page
http://www.swatosch.de/zx81
is 2.8 while the documentation refers to 2.7 - so maybe not unusual that the size of driver changed a little bit while the documentation left unchanged. I never took care of correct driver size as it worked to load the driver.

Post Reply