Help diagnosing Issue 2

Post Reply
albertusj
Posts: 58
Joined: Sat Aug 18, 2012 12:44 am
Location: Somerset-West, South-Africa
Contact:

Help diagnosing Issue 2

Post by albertusj » Sat Oct 05, 2019 6:09 pm

I get this picture upon boot:

Image

Image

Is it possible to tell which RAM chip (if it is RAM) has failed? I measured the voltages at the RAM chips and they are all normal.
ZX80/ZX81/ZX Spectrum

User avatar
1024MAK
Posts: 2484
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Help diagnosing Issue 2

Post by 1024MAK » Sat Oct 05, 2019 8:50 pm

albertusj wrote:
Sat Oct 05, 2019 6:09 pm
Is it possible to tell which RAM chip (if it is RAM) has failed?
Not from that image, no.
albertusj wrote:
Sat Oct 05, 2019 6:09 pm
I measured the voltages at the RAM chips and they are all normal.
So the +5V, the +12V and the -5V are all within specification?

That screen display does look like there is horizontal tearing. Have capacitors C25, C34, C44, C45, C46, C47, C50, C74 been renewed? Is this via RF/UHF or has it been modified for composite video?

It’s also worthwhile thinking about carrying out the power circuitry (DC/DC converter) modification (see
here
). But note that some of the capacitors listed by me above change.

Also, it looks like the border is black in colour. If the Z80 CPU was able to run code from ROM, one of the first thing it does is to tell the ULA to set the border to white (this is before it needs working RAM). So the CPU is either not running, or it is running garbage.

Mark

User avatar
1024MAK
Posts: 2484
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Help diagnosing Issue 2

Post by 1024MAK » Sat Oct 05, 2019 9:12 pm

Also, IC26 has pin 11 bent out and a wire soldered to it. That’s not normal.

Which way (if any) are the links between the ULA and IC3 wired?I can’t tell from the photo.

If DRAM chips IC15 to IC22 are soldered direct to the board, then IC24 and IC26 are also normally soldered direct to the board. So it looks like some work has already been done on this board.

TR4 looks unusually twisted.

Are there any other signs of rework on the underside of the board?

Mark

albertusj
Posts: 58
Joined: Sat Aug 18, 2012 12:44 am
Location: Somerset-West, South-Africa
Contact:

Re: Help diagnosing Issue 2

Post by albertusj » Sat Oct 05, 2019 9:26 pm

Right-click on the image and say "Open in new tab". A bigger version will load. There has been some repair/modifications done to the board by a Sinclair service technician by the time I got it.
ZX80/ZX81/ZX Spectrum

Post Reply