Spectrum +3 disk drive issue

Post Reply
Martin Page
Posts: 5
Joined: Fri Sep 23, 2022 11:10 am

Spectrum +3 disk drive issue

Post by Martin Page »

I've had a +3 from the eighties, which I've started using again earlier this year. Naturally the drive belt had gone so I replaced it and everything loaded up perfectly. More recently I've started getting read errors on disks via CAT or LOAD: Drive A; track 0. sector 0, data error... Occasionally I would be able to get a list of programs and if I was really lucky, a program would actually load and run. Yesterday, it showed the error message every time and none of my disks would load or be catalogued. I'm pretty sure there is an issue with the disk drive. I've checked all the connections and carefully lubricated the moving parts. Unfortunately I don't know anyone who has a +3 so I can't try their disk drive in my +3. Any ideas guys?
User avatar
1024MAK
Posts: 4257
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Spectrum +3 disk drive issue

Post by 1024MAK »

Did you clean the drive wheels etc. ? Basically the complete drive belt path.

Bits of old drive belt left stuck behind are know to cause erratic operation.

Failing that, go and visit the Amstrad CPC sites, as the CPC 664, CPC 6128 use similar/same drives. And one of them has lots of servicing details (sorry, I can’t remember which, but it’s likely linked to from within their forum www.cpcwiki.eu/forum/).

Mark
Lardo Boffin
Posts: 1805
Joined: Sat Nov 26, 2016 2:42 am

Re: Spectrum +3 disk drive issue

Post by Lardo Boffin »

I have sent a +3 drive off to here https://www.dataserve-retro.co.uk/index.html to be fixed before.
ZX80
ZX81 iss 1 (bugged ROM, kludge fix, normal, rebuilt)
TS 1000 iss 3, ZXPand AY and +, ZX8-CCB, ZX-KDLX & ChromaSCART
Tatung 81 + Wespi
TS 1500 & 2000
Spectrum 16k (iss 1 s/n 862)
Spectrum 48ks plus a DIVMMC future and SPECTRA
Martin Page
Posts: 5
Joined: Fri Sep 23, 2022 11:10 am

Re: Spectrum +3 disk drive issue

Post by Martin Page »

Thanks for the replies. I removed the disk drive and checked everything. I must have disturbed something because when I had reassembled it the error came up: Disk Drive Not Ready. I then operated with the cover open and noticed that although the disk was spinning, the read head wasn't moving across to read the disk. So now I am worse off from when I started! Lardo Boffin, unless anyone can suggest something else to try, I'll probably have to send it off to DataServe for repair.

Martin.
User avatar
1024MAK
Posts: 4257
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Spectrum +3 disk drive issue

Post by 1024MAK »

If you gently move the head (with the power off), does it travel back when you power up and try it again?

Mark
Martin Page
Posts: 5
Joined: Fri Sep 23, 2022 11:10 am

Re: Spectrum +3 disk drive issue

Post by Martin Page »

Hi Mark. I moved the head towards the front and powered up. Neither did it move when I powered it up nor when I input the CAT command. Perhaps the motor that drives the worm gear isn't working. I checked all the connections and they seemed okay but as I said earlier, I may have disturbed something or other when I removed it the first time. I have a multimeter but wouldn't how to use it in this situation.

Martin
1024MAK wrote: Sat Sep 24, 2022 1:43 pm If you gently move the head (with the power off), does it travel back when you power up and try it again?

Mark
User avatar
1024MAK
Posts: 4257
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Spectrum +3 disk drive issue

Post by 1024MAK »

Given that result, it sounds like the problem is an electrical connection problem within the disk drive, not an electrical connection problem between the computer board and the drive.

I’ve only ever changed the drive belt on mine, so don’t have any experience to help you…

Mark
Martin Page
Posts: 5
Joined: Fri Sep 23, 2022 11:10 am

Re: Spectrum +3 disk drive issue

Post by Martin Page »

Thanks Mark.

Martin.
User avatar
1024MAK
Posts: 4257
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Spectrum +3 disk drive issue

Post by 1024MAK »

Some of the links at the bottom of this page may be useful.

Especially this one and this one.

Mark
Martin Page
Posts: 5
Joined: Fri Sep 23, 2022 11:10 am

Re: Spectrum +3 disk drive issue

Post by Martin Page »

Thanks Mark.

I think I've tried everything mentioned in those articles but it still isn't working. In the meantime I've written to DataServe with a view for help or repair...

Martin.
Post Reply