how to verify if a multiface 1 is working correct ??

User avatar
1024MAK
Posts: 5157
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: how to verify if a multiface 1 is working ??

Post by 1024MAK »

Two things:

The Opus has its own bank switched / paged ROM/RAM system, so there must be a switch or something to prevent clashes between them.

The MF1 looks to be missing a lot of logic chips.

Mark
ZX81 Variations
ZX81 Chip Pin-outs
ZX81 Video Transistor Buffer Amp

:!: Standby alert :!:
There are four lights!
Step up to red alert. Sir, are you absolutely sure? It does mean changing the bulb :!:
Looking forward to summer later in the year.
jojo
Posts: 137
Joined: Mon Mar 16, 2020 5:25 pm

Re: how to verify if a multiface 1 is working ??

Post by jojo »

i took all those chips off to verify them in a component tester :-)

i will try to get some sense into the opus coming weekend ,

Need the formatting programm to do so on a pc-floppy .

Anyone ?
Zx81-16k exp.- Spectrum 48 - Spectrum 128- Interface 1 - DIVide - Zx flashcard- Zx printer - Ram turbo-Velleman interface system-Currah microspeech -Ql - 512k exp.- Ql printer - Cst floppy interf.- Double 3.5 floppy- Minerva - Qimi-and much more .
jojo
Posts: 137
Joined: Mon Mar 16, 2020 5:25 pm

Re: how to verify if a multiface 1 is working ??

Post by jojo »

the only result at pressing the nmi-button is speccy reset.

i verified the eprom , and it is ok ( verified against download )


Any ideas ?



- i have ordered the multiface remake pcb , so in an attempt to see if that one works on theis "frankenstein"build spectrum.
Zx81-16k exp.- Spectrum 48 - Spectrum 128- Interface 1 - DIVide - Zx flashcard- Zx printer - Ram turbo-Velleman interface system-Currah microspeech -Ql - 512k exp.- Ql printer - Cst floppy interf.- Double 3.5 floppy- Minerva - Qimi-and much more .
User avatar
1024MAK
Posts: 5157
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: how to verify if a multiface 1 is working ??

Post by 1024MAK »

Ahh, I was going to reply the other day, must have forgotten :oops:

As the Opus also uses it's own ROM, has the previous owner fitted or modified the MF1 board with a switch or some other method to disable/prevent it's ROM and RAM from being paged in?

Mark
ZX81 Variations
ZX81 Chip Pin-outs
ZX81 Video Transistor Buffer Amp

:!: Standby alert :!:
There are four lights!
Step up to red alert. Sir, are you absolutely sure? It does mean changing the bulb :!:
Looking forward to summer later in the year.
jojo
Posts: 137
Joined: Mon Mar 16, 2020 5:25 pm

Re: how to verify if a multiface 1 is working ??

Post by jojo »

Hi mark ,

nothing specific on the front of the pcb ,
m_IMG_5824.jpg
Or on the back ,
m_IMG_5988.jpg
m_IMG_5989.jpg
only multiface enable and the nmi switch have been extended to some wire-posts

all ic's get their 5 volt .

- i have ordered the parts to make a new multiface to try on the output connector of the opus , see if that will work ( need time to get that unit build ) .
Zx81-16k exp.- Spectrum 48 - Spectrum 128- Interface 1 - DIVide - Zx flashcard- Zx printer - Ram turbo-Velleman interface system-Currah microspeech -Ql - 512k exp.- Ql printer - Cst floppy interf.- Double 3.5 floppy- Minerva - Qimi-and much more .
jojo
Posts: 137
Joined: Mon Mar 16, 2020 5:25 pm

Re: how to verify if a multiface 1 is working ??

Post by jojo »

m_IMG_6024.jpg
now waiting for the last components to arrive , and then do some basic testing on a speccy , and if that works well i will put it on the extender connector of the discovery to see if it works there too .

- might be needed to remove the diode on the multiface one
Zx81-16k exp.- Spectrum 48 - Spectrum 128- Interface 1 - DIVide - Zx flashcard- Zx printer - Ram turbo-Velleman interface system-Currah microspeech -Ql - 512k exp.- Ql printer - Cst floppy interf.- Double 3.5 floppy- Minerva - Qimi-and much more .
User avatar
Paul
Posts: 1538
Joined: Thu May 27, 2010 8:15 am
Location: Germanys west end

Re: how to verify if a multiface 1 is working ??

Post by Paul »

Have soldered the edge connector?
It seems to be on the wrong side of the PCB and the plastic end parts need to be taken off.
In theory, there is no difference between theory and practice. But, in practice, there is.
jojo
Posts: 137
Joined: Mon Mar 16, 2020 5:25 pm

Re: how to verify if a multiface 1 is working ??

Post by jojo »

Was only a mock-up , connector not soldered !!
Zx81-16k exp.- Spectrum 48 - Spectrum 128- Interface 1 - DIVide - Zx flashcard- Zx printer - Ram turbo-Velleman interface system-Currah microspeech -Ql - 512k exp.- Ql printer - Cst floppy interf.- Double 3.5 floppy- Minerva - Qimi-and much more .
jojo
Posts: 137
Joined: Mon Mar 16, 2020 5:25 pm

Re: how to verify if a multiface 1 is working ??

Post by jojo »

okay ,

finally came to testing the new pcb , and ......

It is only partly working ;

i get the multiface-menu after pushing the nmi button .

BUT , it looks like i can not select any options ( aka there is no keyboard response )

What might be causing that ?? - tried on a stand alone speccy 48 -



= i noticed that WHEN i can give the multiface a command it only is possible when it looks the screen is being refreshed( looks like a slight blinking taskbar .....)
Zx81-16k exp.- Spectrum 48 - Spectrum 128- Interface 1 - DIVide - Zx flashcard- Zx printer - Ram turbo-Velleman interface system-Currah microspeech -Ql - 512k exp.- Ql printer - Cst floppy interf.- Double 3.5 floppy- Minerva - Qimi-and much more .
Post Reply