Issue 4a docs needed

eccles
Posts: 26
Joined: Tue Dec 24, 2019 10:37 pm

Re: Issue 4a docs needed

Post by eccles »

I found where I thought TR5 could be replaced with a BC213.... a diagram on a website belonging to one 1024MAK :o

Since received some ZTX753, but the bench supply trips it's 800mA limiter with one of those for TR5
Back to the drawing board!
User avatar
1024MAK
Posts: 3135
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Issue 4a docs needed

Post by 1024MAK »

I’ve spoke about this subject on the World of Spectrum forums, but don’t remember any diagram (except data sheet extracts). Could you provide a link please....

The important thing to remember, is that any alternative transistor suggestions are just for electrical equivalent components. The pin out / lead out is likely to be different.

Mark
User avatar
1024MAK
Posts: 3135
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Issue 4a docs needed

Post by 1024MAK »

Oh, and just to confuse things further, the BC213 is also available as the BC213L with a different lead out....

Mark
eccles
Posts: 26
Joined: Tue Dec 24, 2019 10:37 pm

Re: Issue 4a docs needed

Post by eccles »

Quick update

4A: I've ordered an original ZTX213 to replace TR5 - hasn't arrived yet.

4S: - replacing TR7 and D13 resurrected the audio, next to get it loading tapes!
eccles
Posts: 26
Joined: Tue Dec 24, 2019 10:37 pm

Re: Issue 4a docs needed

Post by eccles »

So here's where i'm at:

Issue 4A:
I got some ZTX213s to replace TR5 again, did so - still trips current limiter, and tested the ZTX753 that I put in (it's OK too) Even replaced the 7805 and tested the ZTX650 on TR4 - both OK

So i've gone from a 4A with working 5v, -5v and low 12v with a number of broken lower ram chips, to a completely dead one. Something clearly has shorted or failed in a big way - any suggestions of an approach to take would be useful.

Issue 4S:
This is booting fine. Even with composite mod, the image is rather fuzzy (I can live with it for now)
The big issue with this one now is inability to get any tapes to load. Had been trying my Panasonic hi-fi seperate with all of the noise reduction turned off. If it's any clue, i'm used to the "seek" part of of the load to produce stripey border that is static, or moves up slightly - when I got it to respond at all, it was moving up the screen rapidly.

I'll take an oscilloscope and check out waveforms as suggested by the service manual, but further guidance would be helpful
User avatar
1024MAK
Posts: 3135
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Issue 4a docs needed

Post by 1024MAK »

For your 4A board, what is the situation with the 4116 DRAM chips? Are they fitted or removed?

Mark
eccles
Posts: 26
Joined: Tue Dec 24, 2019 10:37 pm

Re: Issue 4a docs needed

Post by eccles »

Hi Mark

The 4A currently has it's ram all removed. I think something must have given out when i was scoping it out for the clock pulses for comparison with the 4S when I was sorting it out

My limited knowledges suggests something must be shorting to ground for it to be tripping the current limiter like that

The 4S used to trip it when you turned it on from cold (set at 800mA) but would then work if you fired it up straight away - I assumed it was just an inrush issue, but this 4A is tripping it every time

I'm a little hesitant about turning the current limit up incase something fries
User avatar
1024MAK
Posts: 3135
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Issue 4a docs needed

Post by 1024MAK »

On the 4A, remove TR4 from the board, and don’t fit any of the 4116 DRAM chips. Then power up the board and see what the current draw is now.

Mark
eccles
Posts: 26
Joined: Tue Dec 24, 2019 10:37 pm

Re: Issue 4a docs needed

Post by eccles »

Hi Mark

With TR4 and 4116's out of circuit (i've never put them back in, wanted to ensure all my voltages were right, first) the current draw is 397-404mA
User avatar
1024MAK
Posts: 3135
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: Issue 4a docs needed

Post by 1024MAK »

So it does look like there is a problem with TR4, TR5 or the coil then...

Mark
Post Reply