Page 1 of 1

ZX Spectrum not working

Posted: Sat Jan 23, 2021 2:39 am
by marste
This is the motherboard:
This is the trembling image on the screen when on (is alternating between two patterns of random colors and black stripes):
I tried the very nicely explained initial testing procedure and I found "just" these discrepancies:
1) first measure on the voltage regulator gave me arounk 30kohm and not 100+kohm (ps: and I've a 78005 not 7805)
2) tr4 measures went ok, but on tr5 I have around 0.7 on both sides if I measure in +-+ (ok), while I get open circuit on the upper couple and 0.56V on the lower if I measure -+- (while it was supposed to be open circuit and 1.2V determined by other component around anyway, as explained on the minute 10:35)
Ram and inductors measures seemed ok.

Seems to me that the problem (for now at least) might be just on the voltage regulator. What do you think? There are other measures I should try before attempting to replace it in case?

(sorry to bother but my hardware electronic experience started just recently and is pretty noob still)

Re: ZX Spectrum not working

Posted: Sat Jan 23, 2021 1:13 pm
by 1024MAK
Okay, so before getting to those results related to the tests in the video, can you please do the following tests:

Test the voltages on the 7805 voltage regulator and report the results.


Be very careful that a multimeter probe does not slip and short anything out. You can use use the heatsink tab for 0V/GND instead of the middle pin (electrically inside the chip they are connected together). Use this point for the black/negative meter lead unless I specify a different location.

When using a Sinclair 9V UK1400 or 9V EU1400 (I think that's the correct model number for the European version) PSU, the input should be between 10V and 13V.
The output should be between 4.75V and 5.25V.

Then can you please check the +12V and -5V power rails. These are all available on the edge-connector. They are also all available on the pins of one of the 4116 (or equivalent) DRAM chips, for example IC13.

Note that some diagrams in some Sinclair documentation (including some of the manuals) show a "-12V" supply pin as well. Ignore this, the name is supposed to be "~12V" (where the ~ is a wavy line) as this is a AC waveform, not a DC supply. The supply rails that you should test are however, labelled correctly.


A copy of the full data sheet is here

Pin 1 is VBB, which is -5V (-5.5V to -4V).
Pin 8 is VDD, which is +12V (+10.8V to +13.2V) (although lower than 11.5V normally indicates a problem).
Pin 9 is VCC, which is +5V (+4.75V to +5.25V) (the output from the 7805 regulator is normally very close to +5V).
Pin 16 is VSS, which is 0V (ground/GND) Test this by measuring between this pin (black test lead) and pin 1 (red test lead).
(Voltage tolerances taken from here)

Also, let’s look at the +5V and +12V supplies to the video section.
Test pin 14 on the ULA (IC1) for the +5V supply.
Test pins 14, 15 and 16 on IC14 (LM1889) for +12V.


Re: ZX Spectrum not working

Posted: Sat Jan 23, 2021 3:36 pm
by marste
Ciao Mark,
First thank you for the support! :)

Regarding measures:
1) on the voltage regulator: input 11.1, output 4.94
2) on the RAM: Vbb -1.5 (!), Vdd 10.4, Vcc 4.9, Vss 0
3) on the ULA: pin14 4.93 (but pin13 3.8 if useful)
4) on the IC14: all three around 9.5

Re: ZX Spectrum not working

Posted: Sat Jan 23, 2021 6:09 pm
by 1024MAK
The voltages on the -5V and the +12V supplies indicate that transistor TR4 is dead/blown and TR5 may also be dead. You will need a new ZTX651 or ZTX653 transistor (to replace TR4) (ZTX650 type are obsolete). Buy at least THREE. Also buy some ZTX751 transistors to replace TR5 (ZTX213 type are obsolete, but new old stock is sometimes available).

At this stage, keep in mind that the missing -5V supply may have resulted in damage to one or more of the ‘lower’ DRAM chips (the 4116 or equivalent DRAM chips, IC6 to IC13). Indeed, one may have failed and drawn more power from the DC-DC converter formed by TR4, TR5 and the coil, and hence overloaded TR4. So are any of IC6 to IC13 hot to the touch (as opposed to just warm)? Don’t leave the machine powered up for too long in this condition.

Now would be the time to think about buying new electrolytic capacitors and to think about bringing your board (issue 4A) up to the last version, the DC-DC Converter Modification (see here).

Not essential, but you may also want to think about replacing the 7805 with modern DC-DC converter. You can use a Recom, a Traco Power or a MuRata type. But don’t fit this yet, wait until you get the board working properly.


Re: ZX Spectrum not working

Posted: Sat Jan 23, 2021 10:40 pm
by marste
I'm trying to find out the TR4/TR5. PS: there is some TR4/TR5 equivalent of the bc, bd, 2n, 2sa or 2sc types?

Regarding RAM I've tried just few seconds, but seems no one of the chips was getting hot (not even very warm).

Regarding the other changes better I don't try myself if it is not mandatory. With my current skills I would risk to damage more than improve (up to last year since I had terrible experiences in my youth and I was asking friends to solder even basic things when needed)!

What I can do additionally is to use an external regulated power with current limiter to prevent big damages in case (9V 5-700mA)!

Re: ZX Spectrum not working

Posted: Sun Jan 24, 2021 1:25 am
by 1024MAK
Although there are some other transistors that will work in TR4 position, ZTX651 and ZTX653 transistors are still in production and are strongly recommended, as they are the most reliable. They are the same as the existing ZTX650 but have higher voltage ratings.

TR5 can be replaced with a BC307 or BC557 for example, BUT the lead outs are different to the existing transistor. Hence my suggestion of a ZTX751 above, which has the same lead out as the ZTX213.

There is a list of equivalents/replacements here. There is also a list on the World of Spectrum forums but the wiki is more up to date.

I point U.K. members to this U.K. seller. He has transistors listed on this page. If your order is small, then you may not get hit by the charges caused by brexit.

ZTX651 and ZTX751 can also be found from various sellers around the world on eBay or from good electronic parts supply companies. For example, here is one in the EU (this may not be the cheapest).


Re: ZX Spectrum not working

Posted: Sat Feb 20, 2021 7:32 pm
by marste
1024MAK wrote: Sat Jan 23, 2021 6:09 pm The voltages on the -5V and the +12V supplies indicate that transistor TR4 is dead/blown and TR5 may also be dead.
I found the transistors (equivalent ones) and I was almost changing them with a friend but then by chance we were measuring again voltages and found that also Vbb is ok and around -5V!

Since I'm pretty sure of my previous measure (I double checked all of them) I can explain it just from the fact that having used a current limiter power supply as suggested I might have not allowed enough current to be able to complete the -5... :evil:

So up to now the only discrepancies are the ones on the first post I would say but... tried to switch on again and I'm not able anymore to see the screen I was able to see... I see some very distorted lines but almost noise... :?

In this moment I think it is better to wait to give to some more "expert" one to see, maybe in Mahlerts if will happen sometime, or if there is someone around Torino or Milano!...