My Issue 2 continuing problems and Issue 6s fixed

redgatemodels
Posts: 172
Joined: Tue Sep 05, 2023 11:56 am

Re: My Issue 2 Died (but now resurrected)

Post by redgatemodels »

Ok, quick question for the brains out there. In the service manual it states
A significant cause of problems has been found to be failure of the internal power supply
transistor TR4. The circuit may be improved by changing the value of R60 from 100R to 270R and
connecting a 4.7uF electrolytic (preferably radial type) with positive end to TR5 emitter (positive
end of C34) and negative end to TR5 base (to R58).
Now, I have a 4.7uF cap in the recap kit, but looking at my stocks of resistors from other projects I don’t have a 270R. I do have a 240R or 330R. Would either of these be ok, or do I really have to resort to ordering a few off evilbay???

In better news looks like the machine code mod and the video quality mod mentioned were done at the factory, which is good 😁
redgatemodels
Posts: 172
Joined: Tue Sep 05, 2023 11:56 am

Re: My Issue 2 Died (but now resurrected)

Post by redgatemodels »

Since there was no words of wisdom I’ve ordered 10 270Rs, £1.50 including postage :D

Second Speccy from eBay arrived today, it’s a 6S. Not had chance to test it yet, but hopefully will work and will prove the tv works etc.

I may put the series 2 pcb in the rubber key case, effectively restoring it to how it was when I first got it and put the 6S in the plus case. Undecided
User avatar
1024MAK
Posts: 5197
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: My Issue 2 Died (but now resurrected)

Post by 1024MAK »

For C74 (the extra 4.7µF capacitor) see this post

I hate to say it, but the value of R60 changed many times (both within each board issue and between different boards) and the final value is 220Ω…

What value is currently fitted?

If you really want to bring the DC/DC converter circuitry up to the last official Sinclair version, see my blog page here ;-)

However, it’s a bit more challenging doing this on an issue two board. Have a look at photos of other boards to see the ‘flying’ diodes and other components. It’s also a good idea to get rid of the heatsink for the 7805 by fitting a Recom, Traco Power or MuRata switching regulator / DC/DC converter.

Mark
ZX81 Variations
ZX81 Chip Pin-outs
ZX81 Video Transistor Amp

:!: Standby alert :!:
There are four lights!
Step up to red alert. Sir, are you absolutely sure? It does mean changing the bulb :!:
Looking forward to summer being good this year.
redgatemodels
Posts: 172
Joined: Tue Sep 05, 2023 11:56 am

Re: My Issue 2 Died (but now resurrected)

Post by redgatemodels »

1024MAK wrote: Sat Sep 30, 2023 4:57 pm
What value is currently fitted?
Cheers Mark, it’s 100 ohm at the moment
User avatar
1024MAK
Posts: 5197
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: My Issue 2 Died (but now resurrected)

Post by 1024MAK »

Well, if you don’t have a 220Ω, a 240Ω or 270Ω should be okay.

Mark
ZX81 Variations
ZX81 Chip Pin-outs
ZX81 Video Transistor Amp

:!: Standby alert :!:
There are four lights!
Step up to red alert. Sir, are you absolutely sure? It does mean changing the bulb :!:
Looking forward to summer being good this year.
redgatemodels
Posts: 172
Joined: Tue Sep 05, 2023 11:56 am

Re: My Issue 2 Died (but now resurrected)

Post by redgatemodels »

Nice, I have 240R’s in stock with 270’s on the way from eBay :D
redgatemodels
Posts: 172
Joined: Tue Sep 05, 2023 11:56 am

Re: My Issue 2 Died (but now resurrected)

Post by redgatemodels »

Today's results.

First the new 6s equipped rubber key cased Speccy. Boots fine, keyboard membrane is shot as expected. Memory etc tests out fine with the diagnostic rom. This has also proved that either the TV rf input is dodgy or the aftermarket lead I bought is rubbish. Lots of noise on the screen, less so on my big lounge TV.

Next the old s2. On first power up it was worse, white border, black screen. However with a little twiddling with the colour trimmers I got a white border. The diagnostic rom would not boot. Don't know what made me do it but I pressed the ula and hey presto got results. I whipped it out and switch cleaned the socket and pins. After refitting we get the copyright message with a white on white display. Looks like the recapping has sorted the colour tuning too.

Next is to get a new membrane for the rubber case and then some comp mods. Oh and the 4.7uF cap and r60 swap for the s2
User avatar
1024MAK
Posts: 5197
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: My Issue 2 Died (but now resurrected)

Post by 1024MAK »

Remember, it only takes a single poor connection of one of the critical pins to completely screw up a digital computer…

Good to hear of plenty of forward progress :D

Mark
ZX81 Variations
ZX81 Chip Pin-outs
ZX81 Video Transistor Amp

:!: Standby alert :!:
There are four lights!
Step up to red alert. Sir, are you absolutely sure? It does mean changing the bulb :!:
Looking forward to summer being good this year.
redgatemodels
Posts: 172
Joined: Tue Sep 05, 2023 11:56 am

Re: My Issue 2 Died (but now resurrected)

Post by redgatemodels »

1024MAK wrote: Sun Oct 01, 2023 12:17 pm Remember, it only takes a single poor connection of one of the critical pins to completely screw up a digital computer…

Good to hear of plenty of forward progress :D

Mark
Thanks Mark, it’s great to see proper colours on the s2 at last :D

Membrane is on order, s6 is installed in the plus case, will probably be my “working” one with the s2 in the rubber case kept as “archive”
redgatemodels
Posts: 172
Joined: Tue Sep 05, 2023 11:56 am

Re: My Issue 2 Died (but now resurrected)

Post by redgatemodels »

Final test today, plugged the s2 into the big telly and have a super stable white display, better than the 6S which has what is best described as interference on the display. Maybe a recap would cure this too? It might be ok with a comp video mod, we will see.
Post Reply