Can someone confirm something for me?

Emulator and emulator development specific topics
MikeW
Posts: 63
Joined: Tue May 29, 2012 10:56 pm

Can someone confirm something for me?

Post by MikeW »

OK,

I've made my first build of eightyone in a very very long time...

Can someone confirm a couple of bugs do actually exist before I start digging into the code and/or remake my build environment:

1. Pressing Escape to go fullscreen doesn't work properly when using the GDI renderer.
2. If you use Direct Draw rendered, every time you start the app you need to enter the DIsplay settings and toggle GDI/DDraw before it displays anything.

Mike
REX LIES IN WAIT
Moggy
Posts: 2503
Joined: Wed Jun 18, 2008 2:00 pm

Re: Can someone confirm something for me?

Post by Moggy »

No problem with full screen and GDI renderer and yes have to do the toggle jobby if starting with direct draw.

Also the AY is terrible sounding and unusable and the H4th screen emulation isn't correct (when screen is in inverse mode a bug causes the furthest right hand column to only have half a character inverted) a piddling thing I know but emulators are supposed to emulate the real thing no?

Also I think the H4th ROM used is still the one with a slight but important maths bug despite having pointed it out some time ago, though will stand correction on that, the original U.S Treesoft ROM from which H4th is based is ok maths wise as far as I can tell.

EDIT.

Yes just checked, the bugged h4th is still being used 4 years on after being pointed out.
Un-bugged version attached.
Attachments
corrected h4th ROM.zip
(6.18 KiB) Downloaded 13 times
MikeW
Posts: 63
Joined: Tue May 29, 2012 10:56 pm

Re: Can someone confirm something for me?

Post by MikeW »

Yay!

I've fixed my first bug in about 15 years lol.

At least my copy works with DDraw at start up now... I'll have to look into how we go about syncing source/updating ROMs and the like...

There's a few bugs I've noticed myself that I'm working on, but I'll add yours to the list

Mike

[Edit] Before I forget, when I say full screen, I mean pressing Escape to go borderless, not hitting the full screen widget in the window.
REX LIES IN WAIT
Moggy
Posts: 2503
Joined: Wed Jun 18, 2008 2:00 pm

Re: Can someone confirm something for me?

Post by Moggy »

I also used escape for full screen when I tested it and it worked ok and I don't have a "widget" in the window only an X to shut down the emulator.

My build is V1.22
MikeW
Posts: 63
Joined: Tue May 29, 2012 10:56 pm

Re: Can someone confirm something for me?

Post by MikeW »

Ahhh, I see - someone's added some code to remove the window minimise/maximise buttons unless View->Zoom->Custom Size is selected.

I'll figure all this out eventually :D
REX LIES IN WAIT
Moggy
Posts: 2503
Joined: Wed Jun 18, 2008 2:00 pm

Re: Can someone confirm something for me?

Post by Moggy »

Slow and steady Mike, get there in the end! :D

(that's my excuse and I'm sticking to it) :lol:
MikeW
Posts: 63
Joined: Tue May 29, 2012 10:56 pm

Re: Can someone confirm something for me?

Post by MikeW »

OK my current bug list is:

1. Full screen not working properly (Fixed, just needed correct flags passing to SetWindowPos() - Wasn't an issue on Windows 2000 lol)
2. DDraw not working on startup or window border changes (Fixed) (need to reinitialise render on window border changes)
3. ZX Printer isn't working any more
4. Sound is terrible - not exactly a bug, it always was and i never got round to writing the proper sound buffer code (Probably last on my list of jobs)
5. H4TH inverted screen bog
6. Wrong ROM used for H4TH

Anyone want to add anything? - bug wise, we'll deal with new features later.
REX LIES IN WAIT
Moggy
Posts: 2503
Joined: Wed Jun 18, 2008 2:00 pm

Re: Can someone confirm something for me?

Post by Moggy »

MikeW wrote: Mon Jul 19, 2021 9:17 pm OK my current bug list is:

1. Full screen not working properly (Fixed, just needed correct flags passing to SetWindowPos() - Wasn't an issue on Windows 2000 lol)
2. DDraw not working on startup or window border changes (Fixed) (need to reinitialise render on window border changes)
3. ZX Printer isn't working any more
4. Sound is terrible - not exactly a bug, it always was and i never got round to writing the proper sound buffer code (Probably last on my list of jobs)
5. H4TH inverted screen bog
6. Wrong ROM used for H4TH

Anyone want to add anything? - bug wise, we'll deal with new features later.
I wouldn't bother with the H4th inverse bug Mike and to be honest I don't know why I brought it up as it seems to be a feature of the display routine in that ROM rather than a bug and a few of the techies here tried to cure it and got nowhere and gave it up as a bad job.

Some info as to why it happens came from nollkolltroll and can be found here 4th post down and also a picture of said effect which wierdly is cured when using Andy rea's new ULA on real kit.

viewtopic.php?f=7&t=2993&p=32031&hilit= ... rom#p32031


From my own selfish perspective and possibly a few others, AY is important as the tracker , PT3, STC players and other music creation software also written by Andy Rea will only run on Eighty One graphically speaking albeit with borked audio whilst crashing on every other emulator except SZ-81 (something to do with the way Andy used the index registers I think)
Also there has been a fair bit games software with sound produced so would think it would be something to consider.

Just my two bobs worth. :D
Moggy
Posts: 2503
Joined: Wed Jun 18, 2008 2:00 pm

Re: Can someone confirm something for me?

Post by Moggy »

Printer works ok for me. :?

Are you starting some new compilation from scratch Mike with these bugs or is it the up to date version that most are working with? (v1.22)

As the printer works ok so does the full screen via escape key jobby so not sure what needed fixing.

I only ask as it seems pointless fixing things that actually seem to work so if using v1.22 then maybe your copy corrupted perhaps?

Just a thought.
Attachments
test.jpg
test.jpg (55.88 KiB) Viewed 377 times
MikeW
Posts: 63
Joined: Tue May 29, 2012 10:56 pm

Re: Can someone confirm something for me?

Post by MikeW »

Moggy wrote: Mon Jul 19, 2021 11:10 pm Printer works ok for me. :?

Are you starting some new compilation from scratch Mike with these bugs or is it the up to date version that most are working with? (v1.22)
I'm compiling from scratch with the latest 1.22 source on the web. However, I had to do a fair amount of fiddling to get the development environment running on am M1 Mac with parallels desktop. To make sure nothing untoward is happening I've put together a little Windows 7 machine to compile on.
As the printer works ok so does the full screen via escape key jobby so not sure what needed fixing.
The full screen issue will be very dependent on the version of Windows being used. I know the code works perfectly on Windows 2000/XP but I never tested it on anything newer - over the years Microsoft have introduced all sorts of features that change the way you have to do things...

We'll see what happens when the dev pc is finalised.

Mike
REX LIES IN WAIT
Post Reply