Formula One UDG

General games-related topics
Post Reply
Moggy
Posts: 1647
Joined: Wed Jun 18, 2008 2:00 pm

Formula One UDG

Post by Moggy » Thu Sep 28, 2017 9:59 pm

One of the better magazine "Type Ins" circa 1983 by P. Dziwior.

I always had a soft spot for this one even though it's really a time trial in the mould of a top down view Chequered Flag rather than a proper Grand Prix game.

For UDG board users select 128 mode, load the self running F1REM.P file and it will load and run the main program along with he UDG's.

Eighty One users have the emulator in CHR$16 and ZXpand mode no hi-res, RAM in the 8K region selected and have the three files CAR6.U8K, F1REM.P and F1.P in the emulators SD card folder.

Best played played with external keyboard for real zeddy I found.

Have fun.
Attachments
F1 UDG.zip
(5.95 KiB) Downloaded 59 times

User avatar
Andy Rea
Posts: 1451
Joined: Fri May 09, 2008 2:48 pm
Location: notts UK

Re: Formula One UDG

Post by Andy Rea » Fri Sep 29, 2017 8:58 pm

nice i am very much enjoying this one.

regards Andy
6 x ZX81, 1 x TS1500 , 1 x +3e, 1 x timex 2040 printer, 1 x timex 2020 cassette deck, siclair printer and some spectrum

Moggy
Posts: 1647
Joined: Wed Jun 18, 2008 2:00 pm

Re: Formula One UDG

Post by Moggy » Fri Sep 29, 2017 11:09 pm

Thanks Andy.

It is a bit addictive and frustrating too.

User avatar
Jungsi
Posts: 23
Joined: Fri Jan 04, 2013 11:52 pm
Location: Germany - Bavaria
Contact:

Re: Formula One UDG

Post by Jungsi » Sat Jan 06, 2018 12:04 pm

Thanks for the UDG conversions - I like them a lot.

I've tested this one with the following hardware:
UDG set to 128
ZXpand (the older one) with firmware 2.61

After loading F1REM.P the game doesn't start and I get back the message "C/10" on the screen.
My Blog (in German): http://www.jungsi.de

Moggy
Posts: 1647
Joined: Wed Jun 18, 2008 2:00 pm

Re: Formula One UDG

Post by Moggy » Sat Jan 06, 2018 1:11 pm

Jungsi wrote:
Sat Jan 06, 2018 12:04 pm
Thanks for the UDG conversions - I like them a lot.

I've tested this one with the following hardware:
UDG set to 128
ZXpand (the older one) with firmware 2.61

After loading F1REM.P the game doesn't start and I get back the message "C/10" on the screen.
Hi Jungsi.

Could you please look at line ten when you get the "C/10" error message?

If it says LLIST "M=L" instead of CONFIG "M=L" then I suspect that it may be the bug that affected early xpand firmware which causes P files with a "READ ONLY" attribute to send the xpand into normal ZX81 mode, that is it switches out the xpand EPROM.

Check both P files on your PC and see if the file attributes are set at "READ ONLY". If that is the case then remove the attribute and all should be ok.

Regards.
Moggy.

EDIT.

I've just noticed you are having same problem with the other UDG conversions and as I use line 10 in the REMs to alter the memory configuration of the xpand I suspect the "READ ONLY" attribute is the cause which although the "TROLL" V2.61firmware should stop this happening in practice it still happens, to me at least , I find resetting the attributes the only solution.

User avatar
Jungsi
Posts: 23
Joined: Fri Jan 04, 2013 11:52 pm
Location: Germany - Bavaria
Contact:

Re: Formula One UDG

Post by Jungsi » Sun Jan 07, 2018 11:23 am

You are right. The attributes were the problem.

With the firmwareupdate to 2.62 for the zxpand by Charlie the problem was fixed! :-)
My Blog (in German): http://www.jungsi.de

Post Reply