ZX Printer Belt

Any discussions related to the creation of new hardware or software for the ZX80 or ZX81
beanz
Posts: 20
Joined: Tue Feb 23, 2010 10:36 pm

Re: ZX Printer Belt

Post by beanz » Wed May 22, 2019 5:07 pm

mrtinb wrote:
Wed May 22, 2019 4:59 pm
Maybe you can buy a fax roll, and cut it for 10 cm, and use that, so there's paper between styli and printer roll.
Yes that's an idea...doesn't matter if it actually prints or not...now I think about it will the printer run anyway without paper?? I know the feed button works but don't think I've actually tried to run it via print commands etc.

beanz
Posts: 20
Joined: Tue Feb 23, 2010 10:36 pm

Re: ZX Printer Belt

Post by beanz » Sun May 26, 2019 8:05 am

2nd printer up and running...sort of, it's printing but the styli are not properly "working" so I need to remount them.

The 2nd printer needed the belt printing at 102% to rotate. I also added gun oil on the gears which seemed to help rotation. The fact I'm "custom" making each belt for each printer right now suggests a 3D printed mass market belt isn't an option...at least on the low end 3d printers I have...might be also why Mutant Caterpillar is only offering refurbs on the printer rather than selling the belts themselves, maybe they are custom fitting them.

I think I'm going to try the stapler trick that was mentioned very early in the thread, I know years ago I tried it using that build guide (using a record player belt) and the stapler posts seemed to work, though the belt ultimately didn't...so I guess it's worth a try using the staple method on the 3D belt as that's the time sink really when putting these things together, that being trying to get the styli on the printed posts and then having them stay on while still allowing the movement it needs.

beanz
Posts: 20
Joined: Tue Feb 23, 2010 10:36 pm

Re: ZX Printer Belt

Post by beanz » Tue May 28, 2019 4:30 am

The staple solution works great, very firm and easy to do in a couple of mins rather an 1hr. A bit of insulation from a 22awg wire fits perfectly as the cap on the staple, nice and tight no glue needed so the stylus moves freely as it should.

See photos, The print is blurring as it goes to the right though..anyone got any thoughts on that? remember I've printed the belt slightly bigger so I was wondering if the spacing of the posts is now causing the blurring as it will be slightly more apart because of the extra length...which at 102% slightly under 2mm.

Really happy with the post solution though..saves a bunch of time and is really solid.

inside of belt (belt turn inside out). Staple added and top snipped off leaving the post you see
Image

Belt right side out with stlyi mounted and held on with 22awg wire insulation, just stripped it off a wire, pushed it on (it's nice and tight) then snipped it down to size.
Image

Mounted in the printer
Image

Blurry print as it goes to the right.
Image

Post Reply