ZXmore - questions and answers (FAQ)

Any discussions related to the creation of new hardware or software for the ZX80 or ZX81
dessony
Posts: 234
Joined: Tue Oct 29, 2013 2:26 pm
Location: Indiana, USA

Re: ZXmore - questions and answers (FAQ)

Post by dessony » Sat Feb 13, 2016 10:24 pm

Found it "printed" in my hands. I just overlooked it. :oops: Thanks!

Dessony

dessony
Posts: 234
Joined: Tue Oct 29, 2013 2:26 pm
Location: Indiana, USA

Re: ZXmore - questions and answers (FAQ)

Post by dessony » Wed Feb 17, 2016 10:08 pm

DSC00179.JPG
DSC00179.JPG (222.7 KiB) Viewed 1785 times
DSC00183.JPG
DSC00183.JPG (195.51 KiB) Viewed 1785 times
DSC00190.JPG
DSC00190.JPG (175.88 KiB) Viewed 1785 times
DSC00180.JPG
DSC00180.JPG (212.77 KiB) Viewed 1785 times
I just uploaded a solder side sketches of the ZXmore.

Thanks,
Dessony
Attachments
ZXmore Solder Side version.pdf
(149.25 KiB) Downloaded 111 times

User avatar
PokeMon
Posts: 2225
Joined: Sat Sep 17, 2011 6:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Thu Feb 18, 2016 12:08 am

Hi,
this looks like the delay of the row counter enable signal does not work as expected.
At least seem to be no relevant delay at all.
Can you proof or measure if R26 is 3k3 (3300 Ohms) and C9 is 47nF ?

So resistance between pin 10 of IC6 and pin 12 of IC11 must be 3.3k - you should try to measure with a multimeter to be sure.
Bildschirmfoto 2016-02-18 um 00.02.04.png
Bildschirmfoto 2016-02-18 um 00.02.04.png (59.16 KiB) Viewed 1775 times

User avatar
PokeMon
Posts: 2225
Joined: Sat Sep 17, 2011 6:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Thu Feb 18, 2016 11:51 am

Hi William,

this might be an issue with the actual version 1.7 which does not support NTSC video mode properly.
This gives at least the rolling effect as it hard presents PAL signal whatever you jumper.
You should be still able to switch to instance 1 with the manual rom switch giving the NTSC mode for ZX81 (without ZXmaster control option). This could be another test you could do - take care to set the PAL/NTSC jumper properly for this test.

There might be a dependency between both effects but in fact this may be two different errors as well.
I am still working on the 1.8 version to get it stable for publishing.

Karl

dessony
Posts: 234
Joined: Tue Oct 29, 2013 2:26 pm
Location: Indiana, USA

Re: ZXmore - questions and answers (FAQ)

Post by dessony » Fri Feb 19, 2016 1:51 pm

Pokémon (Karl),

I quoted you, "Can you proof or measure if R26 is 3k3 (3300 Ohms) and C9 is 47nF ?

So resistance between pin 10 of IC6 and pin 12 of IC11 must be 3.3k - you should try to measure with a multimeter to be sure."

Your suspicion was right. My multimeter shows me its reading as 3.27 X 20K. The resistor 26 reads 3270 ohms. I see a capacitor 9 as 473. Yes, it's 47nF(0.047uF to the Americans).

My board has the NTSC jumper set. I am hooking the board up to these CRT color TV and CRT monochrome monitor as you can see from these photos, I submitted here.

William

User avatar
PokeMon
Posts: 2225
Joined: Sat Sep 17, 2011 6:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Fri Feb 19, 2016 2:28 pm

Thanks - so let's wait the update first to release 1.8 supporting NTSC again.
What about choosing instance 1 manually with the rotary switch in position 1, does it show up ZX81 ?
This way NTSC option should work as well if jumper set.

dessony
Posts: 234
Joined: Tue Oct 29, 2013 2:26 pm
Location: Indiana, USA

Re: ZXmore - questions and answers (FAQ)

Post by dessony » Fri Feb 19, 2016 10:09 pm

Good news, yes, I finally saw a inverted "K" on the screen after I fiddled a monitor's vertical size knob! Also the screen, itself, was steady. :D

dessony
Posts: 234
Joined: Tue Oct 29, 2013 2:26 pm
Location: Indiana, USA

Re: ZXmore - questions and answers (FAQ)

Post by dessony » Fri Feb 19, 2016 10:14 pm

Also I tested my ZXmore on the CRT color TV. The board also passed its test! :D I will test the board on the flat panel TV soon.

dessony
Posts: 234
Joined: Tue Oct 29, 2013 2:26 pm
Location: Indiana, USA

Re: ZXmore - questions and answers (FAQ)

Post by dessony » Fri Feb 19, 2016 10:38 pm

Also I put ZXpand and ZXmore together, they work fine. I will test my joystick interface soon.

User avatar
PokeMon
Posts: 2225
Joined: Sat Sep 17, 2011 6:48 pm

Re: ZXmore - questions and answers (FAQ)

Post by PokeMon » Fri Feb 19, 2016 11:28 pm

One further question - when you start ZX81 manually - is the issue with the line counter offset (starting with lower pixel lines on top) ?
So very easy to detect if the K is in the middle of the black block - one black pixel line on top and one black pixel line on bottom of the K cursor.

Post Reply