Page 2 of 2

Re: ZX80 convert .o to .wav

Posted: Wed Apr 20, 2011 9:16 pm
by neazoi
I have tried the PnO2Wav by installing the required .NET framework. It seems to work but I have no idea if the program can run on the zx80. I will connect the computer with the zx80 through a cable and let you know, but what is the process that I have to follow on the zx80 to let it load from the line in?
BTW I have tried it on the eightyone emulator using wave loader bot It does not seem to work unless I am doing something wrong

By the way, sirmorris, have you also the program which leaves the file name, in order to use it in a zx81? please post it here

Re: ZX80 convert .o to .wav

Posted: Wed Apr 20, 2011 10:11 pm
by neazoi
I just tested the zx_p2wav_v0_04
It WORKS great on the emulator.

Re: ZX80 convert .o to .wav

Posted: Wed Apr 20, 2011 11:14 pm
by Prime
Is there something that will go the other way, take a wav recorded off an old tape and convert it to a .p file so I can put it on an mmc and load it with ZXpand ?

Cheers.

Phill.

Re: ZX80 convert .o to .wav

Posted: Wed Apr 20, 2011 11:47 pm
by sirmorris

Re: ZX80 convert .o to .wav

Posted: Wed Apr 20, 2011 11:54 pm
by neazoi
Yes, but this is for the zx81 only, right? We need something for the ZX80..?
BTW, there was a guy here asking for more info on the tapes of the ZX80, In this page you can find some more on the format used: http://www.microwave.gr/giannopk/zxcomp ... nclair.htm

Re: ZX80 convert .o to .wav

Posted: Thu Apr 21, 2011 9:27 am
by nama
I have been recently helping Paul Farrow debug some of his code for his ZX80 Pacman and Donkey Kong (you will notice that these programs have recently been updated as they had issues detecting NTSC or PAL on a real ZX80), and in the process I have learnt a few things about converting from .o to .wav files. Basically I'm using EO to do most of the work, but it's not perfect.

• Firstly I load the .o into EO, then 'save' it to a wav file.
• I then load this wav file onto a real ZX80. The problem here is that for some reason after the wav has finished, the ZX80 will not drop back into BASIC. It's as if it's expecting something to tell it that the program has finished loading. If I start playing the same, or another .wav file after a short time the computer will drop back to the BASIC prompt with the program loaded.
• I then re-save the program from the real ZX80 back to my computer as another .wav file. I then boost the amplification using Audacity (what a great program). This file when re-loaded into a real ZX80 has no issues and drops back to basic and runs flawlessly.

I really wish there was a program that could do the opposite and make .wav into .o files. Something similar to the ZX81 tape utils Java app.

Phil

Re: ZX80 convert .o to .wav

Posted: Thu Apr 21, 2011 1:20 pm
by neazoi
have you used the zx_p2wav_v0_04 to convert o to wav?
It worked ok for me on the emulator, it should work ok on the real zx80 too.
The other program presented here had these issues you refer to and did not work ok. I also noticed a difference in the tones frequency

Re: ZX80 convert .o to .wav

Posted: Thu Feb 07, 2019 2:16 pm
by neazoi
Oliver wrote:
Thu Feb 24, 2011 10:57 pm
Here is the tool that should auto-detect ZX81 and ZX80 files (.p/.o/.80 etc) and convert to a sound file:

zx_p2wav_v0_04.zip
No this does not generate the correct wav files (zx80) wy the drag and drop option. However it works perfectly fine when it runs from the command line :)

Re: ZX80 convert .o to .wav

Posted: Sat May 25, 2019 6:57 pm
by marste
Cesar time ago suggested me a method using his ZesarUX: when you load the program you will find the uncompressed waveform in the tmp directory.
If I remember I used audacity to play it back properly; for me from the PC headphone jack to the real ZX80 direct cable was important to amplify really a lot the signal (I think I wrote the full procedure with details here in the forum somewhere, but again by heart was 2x the waveform at 150% gain playback volume)...