ZX81 rebuild

Discussions about Sinclair ZX80 and ZX81 Hardware
User avatar
mrtinb
Posts: 1203
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: ZX81 rebuild

Post by mrtinb »

Moggy wrote:
Fri May 22, 2020 1:14 pm
5) It plays nicely with external keyboards. Try typing something at a normal typing speed with Toddy forth whilst using a Memotech keyboard and see how you get on.
Keyboard routine in Toddy Forth 1.3 is new.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

Moggy
Posts: 1989
Joined: Wed Jun 18, 2008 2:00 pm

Re: ZX81 rebuild

Post by Moggy »

mrtinb wrote:
Fri May 22, 2020 5:33 pm
Moggy wrote:
Fri May 22, 2020 1:14 pm
5) It plays nicely with external keyboards. Try typing something at a normal typing speed with Toddy forth whilst using a Memotech keyboard and see how you get on.
Keyboard routine in Toddy Forth 1.3 is new.
Unfortunately it only seems to work in an emulator.

I tried this on 5 different zeddies with UDG card and without and whether set for 64 or 128 UDG all I get is garbage. The Toddy V1.3 in the same folder also produces garbage. Tested my other UDG programs no problems so unless there is some magic I'm not aware of this isn't much good. :(

User avatar
mrtinb
Posts: 1203
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: ZX81 rebuild

Post by mrtinb »

It shows garbage unless I use LOAD"TFORTH13;X"
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

Moggy
Posts: 1989
Joined: Wed Jun 18, 2008 2:00 pm

Re: ZX81 rebuild

Post by Moggy »

mrtinb wrote:
Fri May 22, 2020 6:51 pm
It shows garbage unless I use LOAD"TFORTH13;X"
AAAAGGGH Now I remember, Kelly tends to do some of his work using the "X" command when it runs, his UDG poker is a good example of this.

Many thanks for the reminder Martin very grateful. :D

User avatar
mrtinb
Posts: 1203
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: ZX81 rebuild

Post by mrtinb »

I have looked at the source for ToddyForth.

When the code uses UDG, the source only contains missing characters. The rest of the characters are copied to the area $3000 from the ROM.

The area of the char set is not present in the ZXpand ROM, because the ULA will fetch the chars from the internal ROM whether the ZXpand is connected or not. Therefore the area where the characters normally exist in the internal ROM is filled with code in the ZXpand ROM.

That is why only the new chars work, and chars copied from ROM is garbled.

A fix has to be made to the ToddyForth source, so the ZXpand is disabled while the copying of the characters are taking place.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
Erm
Posts: 148
Joined: Thu Jun 20, 2019 7:07 pm

Re: ZX81 rebuild

Post by Erm »

Lardo Boffin wrote:
Fri May 15, 2020 3:20 pm
I just got one of these off eBay, possibly from someone on here?


733632C1-0559-4558-B954-A604D17E48F9.jpeg


Loving the keyring! Nice bonus. 8-)
Bloody 'ell, just got back onto the forum after days of no access due to that server issue, forgetting my password and the recovery option always resulting in an SQL error without saying what the problem was (I think the password required at least one upper-case letter) and now it works! Had no response from the forum administrator over email, must have gone into his spam folder.

Guilty as charged, it was me who sent you that ROM kit Lardo! Pleased you like the keyring, bit of fun isn't it.

I'm afraid I was unaware of the Forth ROM bug, the data on the chip is the original (slightly wrong) one. I've changed the 2 bits for the future.
I'm Chris, a Brit in Germany (Chr$ on the QL forum).

Post Reply