My first wire wrap: Wilf's AT keyboard interface

Discussions about Sinclair ZX80 and ZX81 Hardware
User avatar
gammaray
Posts: 461
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

Re: My first wire wrap: Wilf's AT keyboard interface

Post by gammaray » Mon Feb 05, 2018 3:52 pm

Great news! Can't wait to see output from your temporary dipswitch.
Finish what you start. Truth is over the mountaintop or six feet under.
4 x TS1000, 2 x TS1500 , 2 x timex 2040 printer, 1/2 x timex 2020 cassette deck, ZXPAND+AY, ZeddyNET, ZXBlast..., unfinished Spectrum...Still no life!

User avatar
mrtinb
Posts: 685
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: My first wire wrap: Wilf's AT keyboard interface

Post by mrtinb » Mon Feb 05, 2018 4:09 pm

Before I went to bed I found one switch was not pulled to ground. Maybe it's a resistor or socket that's faulty. Maybe I have time tonight for further investigation with my logic probe.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
mrtinb
Posts: 685
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: My first wire wrap: Wilf's AT keyboard interface

Post by mrtinb » Mon Feb 05, 2018 10:52 pm

Image

I’ve fixed error on pin 23. It’s now LOW as the others.

The error on pin 5, I don’t know what’s wrong. My only suggestion would be to replace the EEPROM with a new one and see if that fixes the problem.

Image
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
mrtinb
Posts: 685
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: My first wire wrap: Wilf's AT keyboard interface

Post by mrtinb » Sun Feb 11, 2018 10:05 pm

I've changed the EEPROM, and checked that A13 is not connected to anything other than A5 on the EEPROM. It didn't fix anything.

Can anyone suggest why A13 is Pulse-Low, when everything else is Pulse-High-Low?

When the card is not connected to the ZX81, then A13 is Pulse-High-Low.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
mrtinb
Posts: 685
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: My first wire wrap: Wilf's AT keyboard interface

Post by mrtinb » Sun Feb 11, 2018 10:28 pm

I just realized my EEPROM never gets Chip Enable signal, at the Arduino controller is not yet implemented. I need a switch for Chip Enable instead.

Back to the drawing board. :)
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
gammaray
Posts: 461
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

Re: My first wire wrap: Wilf's AT keyboard interface

Post by gammaray » Mon Feb 12, 2018 12:12 am

Why is Vss on EPROM connected to 0V? Is that supply or sink voltage?

Nevermind it's ground.
Finish what you start. Truth is over the mountaintop or six feet under.
4 x TS1000, 2 x TS1500 , 2 x timex 2040 printer, 1/2 x timex 2020 cassette deck, ZXPAND+AY, ZeddyNET, ZXBlast..., unfinished Spectrum...Still no life!

User avatar
mrtinb
Posts: 685
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: My first wire wrap: Wilf's AT keyboard interface

Post by mrtinb » Mon Feb 12, 2018 12:18 am

I assume it’s GND on the 28C64 EEPROM I’m using. Look at previous post for my schematic
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube

User avatar
gammaray
Posts: 461
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

Re: My first wire wrap: Wilf's AT keyboard interface

Post by gammaray » Mon Feb 12, 2018 12:30 am

Is it significant A13 is not connected to ROM? Nor internal RAM?

A14 and 15 connect to ULA.
Finish what you start. Truth is over the mountaintop or six feet under.
4 x TS1000, 2 x TS1500 , 2 x timex 2040 printer, 1/2 x timex 2020 cassette deck, ZXPAND+AY, ZeddyNET, ZXBlast..., unfinished Spectrum...Still no life!

User avatar
gammaray
Posts: 461
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

Re: My first wire wrap: Wilf's AT keyboard interface

Post by gammaray » Mon Feb 12, 2018 12:34 am

I saw the post and schematic but I second guess everyone and every thing as there are land mines everywhere!
Finish what you start. Truth is over the mountaintop or six feet under.
4 x TS1000, 2 x TS1500 , 2 x timex 2040 printer, 1/2 x timex 2020 cassette deck, ZXPAND+AY, ZeddyNET, ZXBlast..., unfinished Spectrum...Still no life!

User avatar
gammaray
Posts: 461
Joined: Sun Apr 17, 2016 2:44 am
Location: Texas

Re: My first wire wrap: Wilf's AT keyboard interface

Post by gammaray » Mon Feb 12, 2018 12:36 am

The ROM routine sets RAMTOP for 1k ( I assume you do not have a memory pack on back) and maybe never addresses with A13.
Finish what you start. Truth is over the mountaintop or six feet under.
4 x TS1000, 2 x TS1500 , 2 x timex 2040 printer, 1/2 x timex 2020 cassette deck, ZXPAND+AY, ZeddyNET, ZXBlast..., unfinished Spectrum...Still no life!

Post Reply