Re-enable ZXpand after CONFIG "X"

Discussions about Sinclair ZX80 and ZX81 Hardware
Post Reply
User avatar
mrtinb
Posts: 1301
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re-enable ZXpand after CONFIG "X"

Post by mrtinb »

Sometime you disable ZXpand because some software will not work with it.

However how do you save your work, when ZXpand has been disabled?

If you type these three commands ZXpand will be re-enabled again:

Code: Select all

CLEAR
LET A$="[graphic 1] [graphic E] STEP Y [inverse L] GOSUB"+CHR$ 121+"TAN"
RAND USR PEEK 16400+PEEK 16401*256
(There are no spaces in line 2, and commands are not spelled e.g not T A N but FUNCTION TAN.)

Line 2 will look this before pressing NEWLINE:
Image
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube
FrancoisLanciault
Posts: 30
Joined: Thu Jan 18, 2018 11:22 pm

Re: Re-enable ZXpand after CONFIG "X"

Post by FrancoisLanciault »

Thank you Martin,

That can be useful. Is it the same code for the zxpand+ ?

François
User avatar
mrtinb
Posts: 1301
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: Re-enable ZXpand after CONFIG "X"

Post by mrtinb »

It’s the same and thank you.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube
User avatar
Andy Rea
Posts: 1553
Joined: Fri May 09, 2008 2:48 pm

Re: Re-enable ZXpand after CONFIG "X"

Post by Andy Rea »

Nice Trick, Thanks for sharing...

Andy
AFK
Moggy
Posts: 2208
Joined: Wed Jun 18, 2008 2:00 pm

Re: Re-enable ZXpand after CONFIG "X"

Post by Moggy »

Charlie actually showed us this much simpler method some years back, 8 bytes in a REM statement then call as needed.


QUOTE.....


"This should do it.


; re-enable the overlay
ld bc,$e007
ld a,$b1
out (c),a

Here are the hex codes for your favourite hex-code entering system:


01, 07, E0, 3E, B1, ED, 79, C9

and in decimal for the pokers out there:

Code: Select all

1, 7, 224, 62, 177, 237, 121, 201

which are also this week's lottery numbers*.


Full thread here.

https://www.sinclairzxworld.com/viewtop ... =12&t=1007
Attachments
ENABLE.P
(979 Bytes) Downloaded 104 times
User avatar
mrtinb
Posts: 1301
Joined: Fri Nov 06, 2015 5:44 pm
Location: Denmark
Contact:

Re: Re-enable ZXpand after CONFIG "X"

Post by mrtinb »

Yes. That’s the bytes I’m using.

But having a file to load is not helping much, when the ZXpand is disabled.

That’s why I recreated it as a short type-in.
Martin
ZX81, Lambda 8300, Commodore 64, Mac G4 Cube
Moggy
Posts: 2208
Joined: Wed Jun 18, 2008 2:00 pm

Re: Re-enable ZXpand after CONFIG "X"

Post by Moggy »

mrtinb wrote: Tue Oct 01, 2019 6:26 am Yes. That’s the bytes I’m using.

But having a file to load is not helping much, when the ZXpand is disabled.

That’s why I recreated it as a short type-in.
Just poke the 8 bytes into a rem as part of your work to be saved, call it then save, works for me.
Post Reply