RAMPACK and Hi-RES mod ?

Discussions about Sinclair ZX80 and ZX81 Hardware
bola_dor
Posts: 39
Joined: Wed Oct 02, 2019 5:32 am

Re: RAMPACK and Hi-RES mod ?

Post by bola_dor » Fri Nov 01, 2019 5:05 pm

1024MAK wrote:
Fri Nov 01, 2019 1:34 pm
Yeah, it would not surprise me if 1N4148 diodes worked.

Anyway, my diagram for a 7400 / 74LS00 is similar, but I allocated the gates with the use of stripboard in mind:
Hi-Res mod to a 16K RAM pack using a 7400.png

Mark
Oh thank you all @martinb @McKlaud @1024MAK !!!

Will this work?
Attachments
LRM_EXPORT_27537629888726_20191101_124224968.jpeg

User avatar
1024MAK
Posts: 2691
Joined: Mon Sep 26, 2011 10:56 am
Location: Looking forward to summer in Somerset, UK...

Re: RAMPACK and Hi-RES mod ?

Post by 1024MAK » Fri Nov 01, 2019 6:52 pm

Yeah, that will work.

Mark

bola_dor
Posts: 39
Joined: Wed Oct 02, 2019 5:32 am

WRX16 at last...but...

Post by bola_dor » Mon Nov 11, 2019 5:30 am

Well finally I made it and tested it ..
Something is not as expected..
I' ve modified my DIY rampak (photo) it uses two mounted one on too the other 8K SRAM ICs.. (RFSH line was not connected.. I did solder it to the 74LS00 to keep the logic) .. the one soldered on the air is the original 74LS10 that chooses which of the two chips is directed.. the new Hi-Res mod is properly soldered to the board.
I do have Hi res pixels on screen but something is wrong.
I tried the game Starfight.. an d I saw characters were wrong then I tried WRX1K1 which I Konw It works on my hardware without any rampack .. I I use an original TS1016 rampack I get a black box on white frame screen as supposed.. with my modified one drawing is incorrect.. so I think I am at a halfway to get it... but with not a clue...
Help? :oops:
Attachments
20191111_002327.jpg
20191111_002414.jpg
20191111_005829.jpg
20191111_010244.jpg

User avatar
zsolt
Posts: 202
Joined: Wed Apr 20, 2011 11:43 am
Location: Fót, Hungary

Re: RAMPACK and Hi-RES mod ?

Post by zsolt » Mon Nov 11, 2019 5:21 pm

For the two SRAMs I would use this schematic rather
(the /RFSH is not necessary, can be VCC)
(the /RFSH is not necessary, can be VCC)
and i am using this for TS1016
Regards,
Zsolt
ZX81 (8K), ENTERPRISE 128, [ZX SPECTRUM (48K,+,+128K,+2,+2A), TS1000, TS1500, TS2068, Cambridge Z88, PRIMO A64 (red)]

bola_dor
Posts: 39
Joined: Wed Oct 02, 2019 5:32 am

Re: RAMPACK and Hi-RES mod ?

Post by bola_dor » Tue Nov 12, 2019 12:33 am

zsolt wrote:
Mon Nov 11, 2019 5:21 pm
For the two SRAMs I would use this schematic rather
SRAM.png

and i am using this for TS1016
Regards,
Zsolt
Wow.. Will that solve the problem? What do you think is happening in my mod?
About the "without components" mod.. I have some doubts I marked on the picture..
Purple arrow: is the thick way cutted ?
Green arrow: are the three leads soldered together? Or do I have to skip the one in the middle and solder this on the other side..(isn't it the same?)
Orange arrow: do I have to cut and lift this lead and solder the wire losing contact with the board??
Thank you!!
Attachments
Screenshot_20191111-202311_Chrome.jpg

bola_dor
Posts: 39
Joined: Wed Oct 02, 2019 5:32 am

Re: RAMPACK and Hi-RES mod ?

Post by bola_dor » Tue Nov 12, 2019 1:17 am

zsolt wrote:
Mon Nov 11, 2019 5:21 pm
For the two SRAMs I would use this schematic rather
SRAM.png

and i am using this for TS1016
Regards,
Zsolt
Would you explain this to me please.. I don't know much about electronics and a very little on logical circuits..
Those are NAND gates so IF A13 is used as an entry in both lead the output to CS2 will be necessarily 0 always?
But A13 is connected to CS2 anyway? And to VCC ?? Should I use A13 as VCC? Or am I putting VCC to A13? I am sure I am getting this wrong... so I' will wait before making any damage :oops:
Attachments
20191111_210913.png
20191111_210913.png (69.92 KiB) Viewed 1107 times

bola_dor
Posts: 39
Joined: Wed Oct 02, 2019 5:32 am

Re: RAMPACK and Hi-RES mod ?

Post by bola_dor » Tue Nov 12, 2019 1:22 am

bola_dor wrote:
Tue Nov 12, 2019 1:17 am
zsolt wrote:
Mon Nov 11, 2019 5:21 pm
For the two SRAMs I would use this schematic rather
SRAM.png

and i am using this for TS1016
Regards,
Zsolt
Would you explain this to me please.. I don't know much about electronics and a very little on logical circuits..
Those are NAND gates so IF A13 is used as an entry in both lead the output to CS2 will be necessarily 0 always?
But A13 is connected to CS2 anyway? And to VCC ?? Should I use A13 as VCC? Or am I putting VCC to A13? I am sure I am getting this wrong... so I' will wait before making any damage :oops:
Ohhhh I see!!!
Is a NOT gate and the rectangles ar the two ICs mounted on top the other :o :?
I am a bit slow at this :lol:

User avatar
zsolt
Posts: 202
Joined: Wed Apr 20, 2011 11:43 am
Location: Fót, Hungary

Re: RAMPACK and Hi-RES mod ?

Post by zsolt » Tue Nov 12, 2019 1:13 pm

bola_dor wrote:
Tue Nov 12, 2019 1:22 am
Is a NOT gate and the rectangles ar the two ICs mounted on top the other :o :?
Yes - sorry for the sketch, just the Excel was at hand.
bola_dor wrote:
Tue Nov 12, 2019 12:33 am
About the "without components" mod.. I have some doubts I marked on the picture..
Purple arrow: is the thick way cutted ?
Green arrow: are the three leads soldered together? Or do I have to skip the one in the middle and solder this on the other side..(isn't it the same?)
Orange arrow: do I have to cut and lift this lead and solder the wire losing contact with the board??
Purple arrow: cut and lift pin 9, then
Green arrow: solder the three pins (9-10-11) together - it was easier for me to do it in two steps (bottom: 10-11, then top: 9-11)
Orange arrow: yes, you have to connect it (lifted pin 2) to pin 8

Do not forget the bottom (solder) side of the board:
cut wiring between pins 12-13 and cut wire to pin 11 (red Xs on the picture - only one movement :D)
then make contact between the hole of pin2 and pin 13 as on picture.

finally solder pin 1 w. pin 2 of the LS393 (the other IC)
Regards,
Zsolt
ZX81 (8K), ENTERPRISE 128, [ZX SPECTRUM (48K,+,+128K,+2,+2A), TS1000, TS1500, TS2068, Cambridge Z88, PRIMO A64 (red)]

bola_dor
Posts: 39
Joined: Wed Oct 02, 2019 5:32 am

Re: RAMPACK and Hi-RES mod ?

Post by bola_dor » Thu Nov 14, 2019 11:53 pm

zsolt wrote:
Mon Nov 11, 2019 5:21 pm
For the two SRAMs I would use this schematic rather
SRAM.png

and i am using this for TS1016
Regards,
Zsolt
I came in doubt with this ..
My DIY rampak has a selecting IC circuit ( I post here my own diagram from about 30years ago) RAM used are 2x 6264
This diagram you are proposing to me here has to replace the existing one allowing the hole to be WRX16 capable or it has to coexist with this preexisting one?
I see many leads are repeated in the two and /RD connection is missing... as I said I am a :P at these matters... all I have done is just copy and solder..
Thanks!!!!
Attachments
20191112_235202.jpg

User avatar
zsolt
Posts: 202
Joined: Wed Apr 20, 2011 11:43 am
Location: Fót, Hungary

Re: RAMPACK and Hi-RES mod ?

Post by zsolt » Sat Nov 16, 2019 12:05 am

bola_dor wrote:
Thu Nov 14, 2019 11:53 pm
... (I post here my own diagram from about 30years ago) RAM used are 2x 6264 ...
It is OK, just do not use the /RD line (remove/disconnect from pin 22 of 6264).
and connect pin 22 to pin 20 (/OE to /CS)
and connect pin 22 to pin 20 (/OE to /CS)
ZX81 (8K), ENTERPRISE 128, [ZX SPECTRUM (48K,+,+128K,+2,+2A), TS1000, TS1500, TS2068, Cambridge Z88, PRIMO A64 (red)]

Post Reply