Page 1 of 1


Posted: Wed Aug 23, 2023 12:49 pm
by MarkAffleck
Hello everyone.

I installed the full 32K on a ZX81 with a vLA81 successfully with a lot of help from Mark (MAK1024)!

The connection to pin 35 on the vLA81 to enable the extended memory addressing has been made. (Z80 address line A13 and one of the SRAM address pins, in this case as it happens, address pin A13).

I found a program on this forum called SYSINFO and have attached two images from its output, with the vLA81 configured for memory mode 1 and 2. The mode 0 output (16K only) is what I expected, so onwards to try the other modes….

What I see for mode 1 is what I was expecting, but the mode 2 image completely threw me as I expected to see the RAM entries starting at Hex 2000.

NB: At this point I haven’t thought too much about how to use the mode 3. Perhaps someone can help with that too.

Am I missing something?

Once again TIA

EDIT: It would be good if I got Mark's user name correct, 1024MAK, sorry Mark!


Re: vLA81

Posted: Sat Aug 26, 2023 4:07 pm
by 1024MAK
Both your photos show a mode 1 configuration.

What positions are USR0/USR1 switches?

Did you try using the soft configuration?

Mode 3 is only useful if you have a machine code program that can run without using any of the ROM routines, and which does not exit to BASIC (unless the ROM is switched back in).


Re: vLA81

Posted: Mon Aug 28, 2023 10:45 pm
by MarkAffleck
Hi Mark,

I have finally got the 32K RAM installed with a connection to pin 35 of the vLA81 and the Z80 address line successfully, with the help that you supplied!

Ignoring memory mode 0, no matter how I set the USR0 / USR1 switches the memory mapping is always as shown in the images.

I contacted Charlie Ingley with included images of my final setup for some help with this and he has kindly sent several emails back with some detailed information.

BTW he did confirm that the solder bridge across the two pads on the configuration switch block was a common rail and although shouldn’t have been there, would not cause an issue, as you had stated in my original post.

Charlie thinks that the symptoms point to a missing A13 connection to the vLA81, so one check he suggested I have now carried out and reported back to him is:

To check from pin 3 of the Z80 to the top header pin 35 of the vLA81. From pin 35 of the vLA81 pin header, A13 then connects to pin 31 of the CPLD. (He included a diagram of the CPLD). Continuity checked out Ok.

He has now suggested the following:

Checking for bad solder joints. None that I am aware of.

To make sure that the vLA81 pin 35 wasn’t inadvertently exposed to > 5v. I was careful to ensure that did not happen.

Maybe the A13 signal is not within specification. He suggested that I check the waveform of this connection and compare with other address lines, unfortunately I don’t have an Oscilloscope.

Because A13 also goes to the keyboard, try another membrane if possible. I will be able to try this. (Although I am using a Memotech external keyboard).

That maybe the ZX81 clock circuitry is degrading A13 at the vLA81 pin 35. The ceramic resonator should provide a high enough impedance to not cause issue but try removing it temporarily. I will be able to do this.

I do have another ZX81 with an internal 16K RAM mod which is back in the case etc.

I have been reluctant to open it up and try the vLA81 in it only because of having to open it up again and reconfigure things but if all else fails I will do.

Charlie has been very helpful, as have the forum members and yourself, and has stated that he is very happy to refund or replace. I certainly am not after a refund and if it turns out that this unit is faulty, I will get the replacement.

I will post back when I get this resolved!

Thanks all,


Re: vLA81

Posted: Mon Aug 28, 2023 11:03 pm
by 1024MAK
I think it very unlikely that either the ULA clock/resonator circuitry or the clock to the Z80 (pin 6) would be causing these problems. The Z80 does a reasonable job of driving the address lines.

However, it may be that there is a thin solder tail that is shorting another signal to A13. Do ALL the keys on the keyboard work? If yes, then this is also not likely.

Just for a sanity check, it may be an idea to test ALL the address lines from the SRAM chip to their respective Z80 pins. But do keep in mind that they are not all connected logically. See the post here for the Sinclair “way”… (also not the difference between pin numbering foe a 24 pin chip to a 28 pin socket…

The other possibility is that the output driver for A13 pin on the Z80 is damaged. It’s possible for it to fail such that is can no longer drive both high and low, but only drive one way.


Re: vLA81

Posted: Tue Aug 29, 2023 5:45 pm
by MarkAffleck

I will do what you suggest and check the board again for any solder splashes and do that sanity check.

I have got another ZX81 which I can test the vLA81 in, I’ve just been a bit reluctant up till now because it’s all back together etc.

It’s an internal 16K RAM with the standard ULA in so obviously I’ll have to reconfigure it, but if the further tests on this one proves negative then I guess that will be the ultimate test.

I presume I wouldn’t have the same issue with two ZX81’s and if I get the same issue, it must be the vLA81



Re: vLA81

Posted: Fri Sep 29, 2023 12:16 pm
by MarkAffleck

Just an update on the vLA81 issue that I have been experiencing.

Having followed all the suggestions offered to me, I eventually tried it in my other ZX81 with the same result.

Charlie Ingley (the Creator of the vLA81 for those that don’t know) has been incredibly helpful, as have these forums users, and ultimately decided that the unit must have developed a fault so sent out another one directly to me, and even declined my offer to cover shipping costs!

It works!!

Anyway, thank you to everyone that offered help with this. I can say that during this ‘voyage’ I have learnt a lot more about how the ZX81 works, especially the memory mapping.

Mark Affleck

Re: vLA81

Posted: Sat Sep 30, 2023 5:19 pm
by 1024MAK
MarkAffleck wrote: Fri Sep 29, 2023 12:16 pm It works!!
Yay :D