Page 5 of 8

Re: ZX81 ULA

Posted: Sat Jul 07, 2018 3:21 pm
by Moggy
gammaray wrote:
Fri Jul 06, 2018 11:27 pm
I am going to put a heatsink on mine! :D
My attack moggy (Keith) loved this so much he asked me to post this.

He also muttered some thing about booking a flight to the lone-star state for him and his M16 to enjoy a short hunting holiday. :twisted: :twisted: :twisted:

Re: ZX81 ULA

Posted: Fri Jul 13, 2018 12:17 pm
by fizzyade
The ZX81 I purchased did indeed turn out to have a faulty ULA! Was so happy when this replacement bought the "K" to the screen!

Many thanks Andy!

Re: ZX81 ULA

Posted: Fri Jul 13, 2018 6:14 pm
by Andy Rea
fizzyade wrote:
Fri Jul 13, 2018 12:17 pm
The ZX81 I purchased did indeed turn out to have a faulty ULA! Was so happy when this replacement bought the "K" to the screen!

Many thanks Andy!
great stuff. Happy that its working for you.

Regards Andy

Re: ZX81 ULA

Posted: Thu Jul 19, 2018 12:42 pm
by mrtinb
mrtinb wrote:
Tue Jul 03, 2018 9:22 pm
So tonight I repaired the PCB which had been damaged in the ULA removal process. And added the 1K resistor and ground to the ULA to get it working through the modulator.

Unfortunately it's an unstable gray screen so something has changed. Debugging will continue when I receive my cheap oscilloscope from China.
I have now received my DSO-138, soldered it and got it working. I am ready to debug my ZX81.

Is there thread here, that describes how each of the ULA pins should be on my oscilloscope?

Re: ZX81 ULA

Posted: Thu Jul 19, 2018 6:25 pm
by Andy Rea
Hmmm a while ago i saw these build it yourself scope kits... i thought they had really low band width like 200Khz low ! since as the many of the signals on the ula are switching at Mhz speeds i dont think you are gonna have much joy with that.

i would first check for shorts on adjacent pins, and then check for continuity of all pins to relavent parts of the circuit.

also what modulator is fitted to your ZX81... i only tested the 1k thing with the UK um1233 modulators.

regards Andy

Re: ZX81 ULA

Posted: Fri Jul 20, 2018 7:06 am
by mrtinb
I see your point. The oscilloscope has to be faster than the circuit it measures. :oops: (I know people say these oscilloscopes were bad, but now I know why.)

I’ll debug with my digital probe then. :)

Re: ZX81 ULA

Posted: Fri Jul 20, 2018 7:34 am
by TMAOne
mrtinb wrote:
Fri Jul 20, 2018 7:06 am
(I know people say these oscilloscopes were bad, but now I know why.)
They're not all bad, just not suited for everything. I have a DSO201, a 1 MHz "older brother" of yours that looks like a cell phone. I love it. I keep it in a box of "away mission tools", (just the bare essentials), and it serves quite nicely for any kind of audio problem. I think you'll enjoy yours, just not for this particular application.

What you might want to spend a couple of bucks for is one of those cheap Chinese knock off Logic Analyzers. USB hookup to your computer, free software, and 8 channels at 24 MHz. They're great fun too.

Ian

Re: ZX81 ULA

Posted: Fri Jul 20, 2018 10:02 am
by mrtinb
TMAOne wrote:
Fri Jul 20, 2018 7:34 am
What you might want to spend a couple of bucks for is one of those cheap Chinese knock off Logic Analyzers. USB hookup to your computer, free software, and 8 channels at 24 MHz. They're great fun too.
That's a great idea. Thanks.

Re: ZX81 ULA

Posted: Fri Jul 20, 2018 11:34 pm
by Andy Rea
Bumpety Bumpety...

20 ULA's up for grabs on SMR...

link in forst ppst

Thank you.

Andy

Re: ZX81 ULA

Posted: Sat Jul 21, 2018 12:36 pm
by Lardo Boffin
Got one! :D