sz81 emulator

Emulator and emulator development specific topics
Moggy
Posts: 3333
Joined: Wed Jun 18, 2008 2:00 pm

Re: sz81 emulator

Post by Moggy »

Just tried the latest windows version and whilst the player works, the display/video is made up of the standard ZX81 character set not UDGs.
olofsen
Posts: 189
Joined: Wed Jan 08, 2014 12:29 pm

Re: sz81 emulator

Post by olofsen »

The 2.3.10 source and Windows binaries have been updated with a minor change for UDG. Without this change, the first "BBB" video worked, but hopefully now also the new example videos. A difference is that switching off WRX doesn't seem to be necessary. Hopefully the minor change does not give issues with other UDG programs.
User avatar
djp
Posts: 11
Joined: Sat Apr 22, 2017 3:37 pm

Re: sz81 emulator

Post by djp »

olofsen wrote: Thu Sep 05, 2019 8:44 pm The 2.3.10 source and Windows binaries have been updated with a minor change for UDG. Without this change, the first "BBB" video worked, but hopefully now also the new example videos. A difference is that switching off WRX doesn't seem to be necessary. Hopefully the minor change does not give issues with other UDG programs.
Just tested the updated source for GNU/Linux. Now the videos play without issue! :D

Thanks olofsen. 8-)
Moggy
Posts: 3333
Joined: Wed Jun 18, 2008 2:00 pm

Re: sz81 emulator

Post by Moggy »

Can confirm the windows version works too.

Many many thanks for this. :D
User avatar
GCHarder
Posts: 437
Joined: Sat Dec 14, 2013 7:46 pm

sz81 emulator Problem ZXPand version

Post by GCHarder »

ZXPand-Commander doe not appear to work correctly with the ZXPand version of sz81. See the attached image. It doesn't load the contents of sub-directories for some reason. I'm running Win7 and the latest version of sz81 (I think). Does anyone else have this problem? Is it a Windows/Linux thing? Note the alternative file manager ZXFBB2 works fine, but it doesn't have as many features as ZXPand-Commander, like directly reading text files and BMPs.

Regards;

Greg
Attachments
ZXFBB2.p
ZXPand File Browser if someone wants it.
(2.47 KiB) Downloaded 205 times
Problem Example
Problem Example
olofsen
Posts: 189
Joined: Wed Jan 08, 2014 12:29 pm

Re: sz81 emulator

Post by olofsen »

Hello Greg, under Linux, I have to have upper case names of files and directories, and then the commander does open a subdirectory. I'm not sure how that might translate to Win 7...
Moggy
Posts: 3333
Joined: Wed Jun 18, 2008 2:00 pm

Re: sz81 emulator

Post by Moggy »

Win7 also and spand commander just crashes the emulator so have never bothered with it.
User avatar
kolbeck
Posts: 45
Joined: Sat May 02, 2020 3:10 pm

Re: sz81 emulator Problem ZXPand version

Post by kolbeck »

GCHarder wrote: Mon Apr 24, 2023 10:09 pm ZXPand-Commander doe not appear to work correctly with the ZXPand version of sz81. See the attached image. It doesn't load the contents of sub-directories for some reason. I'm running Win7 and the latest version of sz81 (I think). Does anyone else have this problem? Is it a Windows/Linux thing? Note the alternative file manager ZXFBB2 works fine, but it doesn't have as many features as ZXPand-Commander, like directly reading text files and BMPs.

Regards;

Greg
From your images, looks like the version is a little behind - the latest one I could find, and got working on macOS, is sz81-2.3.12 - I will try it out later :-)
https://api.zxinfo.dk/v3/ - ZXDB API for developers
zxinfo-file-browser - Cross platform app to manage your files
https://zxinfo.dk - another ZXDB frontend
Moggy
Posts: 3333
Joined: Wed Jun 18, 2008 2:00 pm

Re: sz81 emulator

Post by Moggy »

If you re-read Gregs post he, like myself are having problems with Win7, not macOS/Linux and the version we have is, according to the EXE file detail, 2.1.8.1 even though the site lists it as 2.3.10 and is the newest windows version.

Running this version exhibits the faults Greg describes.
olofsen
Posts: 189
Joined: Wed Jan 08, 2014 12:29 pm

Re: sz81 emulator

Post by olofsen »

@Moggy: it seems that sz81 hangs with commander versions > 1.7; the joystick (which is not supported) initialization seems to result in a ZXpand read from an unopened file. Now this can be prevented in the ZXpand emulation or the joystick initialization needs a modification. For now, I've created a test version that excludes the joystick initialization (2.00X). The Windows version string of the executable indeed needs to be updated in a next release.
Attachments
X.P
(8.78 KiB) Downloaded 182 times
Post Reply